Stripline Channel Design

I have the dimensions of a stripline channel from Ads.I have attached it’s image.
Now i want to fabricate this channel in pcb on a 4 layer board. How do i layout this channel in KiCad? Can someone point me to a demo/doc/video tutorial to get started on this.

Thanks in astripline_layout dvacne!

This might help. Complex shapes are sometimes best handled in programs designed for complexity. Other’s might have simpler solutions.

1 Like

With routing of differential pairs, there is a “length tuning” feature, and you can set several parameters for the meanders. Here I set them for an amplitude of 20mm on both sides and a spacing of 3mm.

KiCad does not have much support for rounded tracks though. If you enable viewing of clearance and zoom in you can clearly see that the bends are made from a number of straight line segments:

KiCad-nightly V5.99 is starting to get some support for real arcs in copper tracks, but it’s still in early stages and not much tools are available yet to make them.

A possible solution for you is to set the parameters for the differential pair length tuning as close as you can, and use a bit of manual post-processing. You can “clean up” one of the meanders, then copy them, make an array or whatever and connect parts again. If you put effort into this, then also lock all track segments to prevent them from being shoved around by the interactive router.

I made the the screenshots by first drawing a differential pair in the schematic (with appropriate labels), then put those nets in Pcbnew, drew a straight differential pair and made the meanders with: Pcbnew / Route / Tune Differential Pair Length. The menu for the Differential pair length tuning settings is hidden. You can find it by first selecting the above “Tune Differential Pair length”, and then right clicking on a track segment of a differential pair and select: Length tuning Settings from the popup menu.

1 Like

Really helpful ! i will try it on my end and see how it goes.

If i know the geometry of the curves ,horizontal and vertical lines can i tune my circuit using Differntial tuning? I will name the nets in schematic as differential convention.

@paulvdh need your help with the following drc error .
I made the channel using single ended wires and bends whose geometrical values i had from ads .attaching the file.layout_kicad-converted.pdf (45.4 KB)
but now i am getting drc error "refer grahic_arc-converted.pdf"graphic_arc-converted.pdf (51.9 KB)

The problem is i used graphic arc to draw those traces and later changed the layer but kiCad doesn’t have any other means to do so. how can i fix this?

Why me?
There are over 5000 users registered at this forum.

And why make screenshots and put those as pictures in a .pdf file? The DRC messages hare quite descriptive about what they find, and also have coordinates, and also show errors on the PCB.
But if you can’t figure it out, it’s much better to just zip the project and post it here. That way you give others the opportunity to correlate the DRC messages with what is on the PCB. Without that combination there is not much to say or write about your problem.

XCVR_Channel.rar (221.5 KB)
the footprint must be reffering to some other path , you can assign it SMA_EDGE_LAUNCH.
Please help me fix the DRC errors

You have still both drawings and tracks there, not all parts of the graphics have been converted to tracks. Therefore you get errors where tracks touch the drawings.

I can’t give any simple solution other than to ignore those DRC messages.

Your PCB project clarifies a lot.
As eelik already wrote, the cause is a mix of copper tracks (the straight sections) and graphical items on a copper layer (the arc’s).

If you turn on: Pcbnew / Preferences / Preferences / Pcbnew / Display Options / Clearance Outlines / Track Clearance: Show Always then it becomes clear immediately. The straight lines have a clearance outline, while the graphical arcs do not.

Note the red DRC errors at each section where a straight track meets an graphical arc.

At the moment there is no good support for drawing arcs as copper tracks in KiCad V5.1.x and that is why I suggested the method of using the differential pair routing, which uses straight line segments to approximate arcs.

This differential pair routing does not implement the straight horizontal sections though. A relatively easy way to circumvent that is to let it draw a few 180 degree arcs, and then manually split them into two 90 degree arc’s and draw a horizontal section manually. You only have to do that once, and can then use block copy & rotate functions to draw the rest.

1 Like

Can i generate valid gerber files even though there are these drc errors?will the vendors understand it as a trace instead of drawing ?

XCVR_Channel_footprint.rar (219.2 KB)
Now i have changed my arcs,tracks as foot prints of desired length and connected them manually .i wish to connect these final footprint tracks to sma pad but i am unable to do it .Can anyone please help me with it? please use files arc_60p4_mils and arc_206p2_mils if missinf footprint is prompted in layout.

In Gerber files there are no footprints, no netlist and there is no distinction between “tracks” and “graphic items on copper”. There are just flash codes. So, from the gerbers alone, thee is no way to distinguish between these two.

I am a bit confused about how you drew your stripline channel.
Apparently KiCad thinks each line segment is an individual footprint, but when I load them in the footprint editor I see no graphics. According to the Footprint Editor, your Tx_proj_footprints is also empty. It is even non-existent. (or you forgot to include it in the .rar file).
In KiCad a footprint library is a directory which ends with a .pretty extension, and each footprint in such a library is a separate file.

You’ve gotten into trouble by doing things in a non-standard way, and by the bad support of arcs in tracks in KiCad. Because you are “abusing” footprints in a non-standard way KiCad gets more confused, which leads to more trouble. KiCad only connects to pads in footprints, and your footprints have no pads. Another complication is that your footprints are not part of the netlist, and therefore KiCad refuses to connect tracks to them because it thinks that would generate DRC errors.

The whole concept of footprints only works well if they represent “real” footprints with copper pads to solder parts to.

But to make an even longer story short.
A quick way to get over it is to disable the DRC. You can do that with: Pcbnew / Route / Interactive Router Settings Then set: Mode to Highlight Collisons, and then set: Options to Allow DRC violations:


I drew the stripline by making the geometric shapes as footprints , then making the silkscreen layer in ki_cad.mod file as In1.Cu layer. I don’t know if this is a correct way to do things . I did what you suggested , if i generate gerber files after all these hacks will these file be correct and can be used to fabricate a pcb by any vendor?

I am trying to place a micro via between and In2.Cu but the drc check is throwing an error " incorrect layer pairs (not adjacent)"
how can i fix this error?

Microvia’s can only be made between adjacent layers. This is a limitation of PCB manufacturing hand has nothing to do with KiCad.

ok Thanks for clarification

Maybe you can stack micovia’s on top of each other. Use one between F.Cu and In1.CU and another between In1.Cu and In2.CU. I’m not sure if this is a valid workflow however.

Microvia’s are an extra and uncommon process for making PCB’s, and you have to pay extra for it, while Thru via’s are standard and part of normal PCB manufacturing, so think carafully if you need microvia’s.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.