Step export Disable in KICAD 5 (Manjaro Linux)


#1

Greetings to all and thanks for the excellent work of development of Kicad ;-).
I have a problem, using kicad 5 in windows the export tool in .step is enabled in the menu and it works.
I installed the same version of kicad under linux but this export tool is visible under the corresponding menu but it is disabled.
I searched the internet and found that you need to have installed the OCE package and I have performed this installation but the functionality has not been activated.
Do I have to compile kicad with specific settings? Thank you

Fabio


#2

The manjaro linux package might just be compiled without step support (Maybe a dependency is missing for it or the packager forgot to enable it)

You might want to look into kicad stepup. It offers a lot more powerful tools then just exporting step. But it can be used to do it and it is independent of operating systems and kicad dependencies. It works as long as freecad works on your system. Take a look at this: Kicad StepUp: a Seamless ECAD/MCAD PCB Data Integration


#3

I was reading this in the forum as an alternative.
I will do as you say. Now I install freecad and check if it works.

Thank you

Fabio


#4

KiCad has to be compiled with OCE support enabled (-DKICAD_USE_OCE=ON) for STEP import to work.


#5

Thanks,
I’ll try.

Fabio


#6

I have compiled with the oce enabled option and now I can export to .step.

Thanks again.

Fabio


#7

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.