Spice half bridge gate driver issues

Hi all,

I am reasonably new to KiCad and this is my first post here, so apologies in advance if I offend anyone with my ignorance.

I am building a circuit which ultimately connects to a full bridge (H bridge) output. The circuit as a whole works really well (MPPT charging a “battery”, triangle wave gen etc). However, I cant for the life of me get a gate driver to work. I have been to various websites (TI, Infineon, diode, to name a few), downloaded the spice model and created a footprint. Then I built a basic test rig (ideal supplies, MOSFET H bridge powering a load) and worked through the list of gate drivers (with datasheets in hand), but not one worked.

Now, I imagine the questions here may be “what was the error”, but really, there was a variety of errors, from the spice files not loading in to the symbol editor (saying something about expected lines) through to errors like “doAnalyses: TRAN: Timestep too small;”.

These are the components (gate drivers) I tried:

I was hoping that someone in the community could try any of the above and see if it works for them? I would love to know if I’m just doing something stupid.


There is an example with 2ED2109 at Simulation examples for KiCad/Eeschema/ngspice - #4 by holger .

Hi holger,

Thanks for your reply. This is actually a really good example of my problem. This circuit is the reason I tried this gate driver, and before I installed KiCad 7.0.0-0, this circuit worked. Now if I run the circuit downloaded directly from the forum, it works if I just load it up and run it, however, the moment I open the gate driver symbol properties and look at the simulation model, I get the following warning: “Too many parameters for subcircuit type “2ed2109s06f” (instance: xxu1)
Error: there aren’t any circuits loaded.”

If I try to make my own symbol with the “2ED2109S06F_ng.lib” spice file, I get the following error: 2ED2109S06F_ng.lib:168:3: expected newline

I should say Im using a a Mac (dont judge me, its for work :).

Thanks for any further advice.

Edit: I have just run the 2ED2109S06F simulation on a PC with KiCad 6.0.11 on it and I am able to open the symbol, look at the spice code, then run it again just fine. So, it’s either a version or OS thing I guess.

Just to confirm, it is the version, not the OS. Works fine on 6.0.11, not 7.0.0 or 7.0.1

Generally speaking, when simulating half bridges or power supplies, the voltages are higher than with low power circuits or even ICs. Then it is useful to relax the precision requirements for op and tran simulations by adding suitable options, e.g.
.options chgtol=1e-11 abstol=10p reltol=0.01 vntol=10u
often also the integration method GEAR delivers results when default TRAP fails.
.options method=gear

Simulation models are mostly made without ngspice in mind. Infineon models always need some modifications, other sometimes.

Hi, yes, thank you. I do relax a lot of precision, and it works in 6.0.11, so I’m happy. It’s a little bit of a bummer that 7.0.0 and 7.0.1 dont work for this, because I love many of the spice related updates between V6 and V7 of KiCad. However, I’m sure it’ll all come right.