Some issues I am facing by converting a project from Kicad v5 to v6

I am trying to convert a project from Kicad v5 to v6. I am having some issues to map libs. I don’t want to have an old rescue lib. I want to replace all the old symbols with a new symbol since I don’t like this rescue approach.

However, it looks like Kicad is not finding any. First of all, it looks like Kicad is thinking that my project is still v5 since it may be using old environment variables. I am opening the new generated .kicad_pro that uses the new generated .kicad_sch but it still uses old paths.

So, what I want to do is to manually replace all parts in the board with the new version of it. For that work, I need to have libraries. And Kicad is not finding them.

This is the first issue I am seeing.
It is trying to find old libraries using the Kicad v5 paths.

These are the new paths. I have no clue where I can those variable names.
Grepping the project does not show anything related.
I already removed ~/.Kicad ~/.kicad ~/.local/share/kicad folders.

So, What should I do to fix these paths without changing the original paths? I want to replace the name variable instead. Actually, Kicad would use KICAD6 variables since I am running Kicad v6 now.

Here I am showing that there is no library loaded.

Here I am showing that I have the right newest library and it has files in it

What does ~/.config/kicad/6.0/sym-lib-table look like?

Since your theme looks like Ubuntu I wonder if this is the same as Kicad v6 Library migration problem

This. Ah, I will replace these variables to test. But this folder was removed before generating a new one.

Can you check the contents of /usr/share/kicad/template/sym-lib-table? It should have gotten updated by the package upgrade to use KICAD6_SYMBOL_DIR.

➜ sudo apt-cache policy kicad-symbols
  Installed: 6.0.0-1-202112231423+275f22eb~7~ubuntu21.10.1
  Candidate: 6.0.0-1-202112231423+275f22eb~7~ubuntu21.10.1
  Version table:
 *** 6.0.0-1-202112231423+275f22eb~7~ubuntu21.10.1 500
        500 impish/main amd64 Packages
        500 impish/main i386 Packages
        100 /var/lib/dpkg/status
     5.1.12-202111050921+97c0bfdd~7~ubuntu21.10.1 500
        500 impish/main amd64 Packages
        500 impish/main i386 Packages

assoc-board on  main [⇡!] 
➜ sudo apt-cache policy kicad-libraries
  Installed: 6.0.0-1-202112231422+8~ubuntu21.10.1
  Candidate: 6.0.0-1-202112231422+8~ubuntu21.10.1
  Version table:
 *** 6.0.0-1-202112231422+8~ubuntu21.10.1 500
        500 impish/main amd64 Packages
        500 impish/main i386 Packages
        100 /var/lib/dpkg/status
     5.1.12-202111050919+8~ubuntu21.10.1 500
        500 impish/main amd64 Packages
        500 impish/main i386 Packages

Yeap! Your are right. I am going to replace the other by this one to test.

Alright, since libraries are there now. I just have to replace some parts.

Thanks @craftyjon
Now, is this a bug? How users will know that they have replace the file?

Yes it’s a bug: we aren’t supposed to be migrating library tables from a previous version (you’re supposed to have to start from the new libraries). But I have to figure out how to reproduce it…

Try this.

Clone this repo on this commit. This is a project from 5.1 converted to 6.0.

I am using this version here

Application: KiCad

Version: 6.0.0-d3dd2cf0fa~116~ubuntu21.10.1, release build

	wxWidgets 3.0.5
	libcurl/7.74.0 OpenSSL/1.1.1l zlib/1.2.11 brotli/1.0.9 libidn2/2.3.1 libpsl/0.21.0 (+libidn2/2.3.0) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3

Platform: Linux 5.13.0-22-generic x86_64, 64 bit, Little endian, wxGTK, gnome, x11

Build Info:
	Date: Dec 23 2021 14:23:46
	wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.74.0
	OCC: 7.5.2
	Curl: 7.74.0
	ngspice: 35
	Compiler: GCC 11.2.0 with C++ ABI 1016

Build settings:

Same happens with the footprint files too ~/.config/kicad/6.0/fp-lib-table

Now another issue, it looks like it is not that easy to replace symbols buy using sed anymore. I see that it changes the .kicad_sch file a lot and in different places. Is it right?

Well, since with sed it is complicated. DRC is showing these warnings. How do I update all the symbols? I don’t thing I understand this warning.

Maybe it has something to do with this path, but I am not sure what it means.

Cool. I was able to use the “Change Symbol…” to fix things. It looks like the Warnings on my ERC are reducing fast.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.