[SOLVED] Via is not connected or only connected to one layer

I seem to “randomly” get his error during DRC but I am not sure why or how to resolve it. I have deleted and re-added the via but get the same error. I have added this via in many other places without issue.
I have a 6 layer board, traditional top and bottom layers than GND layer on layer 2 and a 3V1 layer for layer 5. 3 & 4 are for additional routing.

Application: KiCad PCB Editor arm64 on arm64

Version: 7.0.7, release build

wxWidgets 3.2.2
FreeType 2.13.0
HarfBuzz 7.3.0
FontConfig 2.14.2
libcurl/7.88.1 (SecureTransport) LibreSSL/3.3.6 zlib/1.2.11 nghttp2/1.51.0

Platform: macOS Ventura Version 13.4.1 (c) (Build 22F770820d), 64 bit, Little endian, wxMac

Build Info:
Date: Aug 14 2023 15:11:18
wxWidgets: 3.2.2 (wchar_t,wx containers)
Boost: 1.82.0
OCC: 7.7.0
Curl: 7.77.0
ngspice: 38
Compiler: Clang 13.0.0 with C++ ABI 1002

Build settings:

I can’t see your GND plane . . . but I suspect it hasn’t filled to where you have put that GND via . . . did you press B to Re-fill the Zones ?

ah, that is it, however, I have it set to refill zones every time I run DRC. So here is the fill results currently.
I guess it is too close to the BT_ON via which causes it to not grab the GND via.

1 Like

Yup, you can adjust the zone clearance from the fill zone properties . . .



ah, that will help a lot. definitely seemed like the fill gap was awfully large


Whenever I add zone I always change Clearance to 0.25 and Minimum width to 0.2.
I didn’t found (to tell you truth I was not searching for it) if I can somewhere set it as default to not have to edit it each time.

1 Like

One year ago I filed a feature request, which was confirmed. No idea, when it will be implemented, however.

The thread derailed a little into some custom DRC rule stuff …

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.