(solved) Ngspice and "Alternate node sequence" for model - Major problem

I’m having an issue where I’m tearing my hair out.
The situation is:
A very simple circuit with a resistor, two diodes (1N4148) and one transistor (BC847).
The issue is, that the BC847 does not confirm to the SPICE pin sequence. It’s pinout is:
1: B
2: E
3: C
ngspice expects C-B-E for a BJT.
Editing the BC847 in EEschema, I choose “Alternate node sequence” and enter 3 1 2.
This gives me ridiculous simulation results.
NOT using alternative node also gives ridiculous results.
I can of course work my way through all nine permutations here, but an explanation would be nicer.

Am I misunderstanding how alternate nodes work? Or have I missed a tick-box or something somewhere? Or is something basically wrong here?
I attach a screenshot and the Newperia SPICE model (which I trust).

Thanks in advance.

bc847.lib (1.4 KB)

KiCAD 6.0.6 on Lubuntu 20.04

Thanks, but no cigar.
Voltage levels look better, but the currents are still crazy.
What’s going on here?

OK, seem to have solved it temporarily for this instance.
using .MODEL type of files, the alternative nodes work.
In .SUBCKT types it doesn’t.
Changing the transistor SPICE model to a .mod file solved it.

This has to be a nasty bug. My trusty old HP-15C was right (as always).

Please also show your circuit file (project or at least ngspice netlist), not only the model file.

Did you check the alternate node sequence for the two diodes?

is is enough to post the .pro file or does the .sch file have to be there as well?
The diode alternative sequence is OK, but as they are .mod files that was to be expected.
The problem sems to lie with the .lib subckt types of models.

Problem solved, user error. An ERC showed bad annotations. After correcting, simulations run.
Sorry for the trouble.
I won’t forget ERC in the future, scout’s honour.