[SOLVED] Kicad v7 on Ubuntu 22.10 (Kinetic)

Thanks, that indeed was the issue. I don’t recall having installed them because it was a long time ago. Those libs date from Jul 11, 2022. Doing what @Stefan-Olt did fix it for me. I removed manually all those outdated libs.

Here is the magic, if someone wants to copy and paste.

sudo rm -rf /usr/local/lib/libwx_*

Thanks @retiredfeline @craftyjon @Stefan-Olt

1 Like

The next issue I am seeing is this one :


Did you also build wxPython from source?

probably. in the past I was testing some things with wxwidgets and I may have compiled it myself since the current version at that time was not working or it was missing.

I installed on a clean system 22.04 of ppa kicad 7 works but creates two shortcuts and there are no language packs on win 10 everything is fine

This file /usr/share/applications/kicad.desktop is a symlink. You can delete it, and one of the Kicad icons will disappear. This is a workaround while they don’t fix it.

sudo rm -rf /usr/share/applications/kicad.desktop
1 Like

Maybe your dog did it? Were there any pawprints on your keyboard around that time? Does the dog avoid your eyes and have a guilty look when it hears the sounds “key cat bug”? :dog: :rofl:

Seriously though, be careful with shared libraries. Installing your own may solve immediate problems but can stuff you up down the line.

Seriously though, be careful with shared libraries.

Nah. I do whatever it takes to run whatever I want to run… computer serves me, not the other way around. If it is complaining a lot, I format it and that’s it. I don’t have animals. =)

Was it really impossible to check before sharing?

Check what? The point is that I did not know what to check. And this discussion highlighted what could be the issue.

There are ways of installing a shared library so that its scope is limited to the application you are trying to run, taking advantage of LD_LIBRARY_PATH. But that’s another rabbit hole.

yeah, I just use the first thing that works for me since my goal is not to improve the installation but use that thing to do something else. anyways, thanks for your help. it is working flawlessly now.

Check installation on pure ubuntu in public publication

The multiple icon issue is easily solved, just remove one of the links.

I have however created a issue for it.

And what to do with non-working language packages? Thank you

Best would be to raise a issue with that so the developers are aware.

Help / REport Bug

8 posts were split to a new topic: Python API not available to system python from OS console

A post was split to a new topic: Help me with KiCad and wxWidgets 3.2

A post was split to a new topic: Problem upgrading v6 to self-compiled v7 on Ubuntu 22.04