[SOLVED] Kicad v7 on Ubuntu 22.10 (Kinetic)

cannot confirm

Application: KiCad x86_64 on x86_64
Version: 7.0.0-da2b9df05c~163~ubuntu22.10.1, release build
Libraries:
    wxWidgets 3.2.2

ubuntu Mate

maybe try a re-install

I did it a bunch of times. I am going to try on a new system, maybe mine is broken somehow, then.

Everything is fine with your 22.10 system… This curve is an unfinished assembly with two shortcuts and no language packs

I’m not sure if I should start a new topic, but I’m having the same issue on Ubuntu 22.04 (Linux Mint):

22:07:42: Failed to load shared library ‘/usr/lib/kicad/bin/_eeschema.kiface’: /usr/lib/kicad/bin/_eeschema.kiface: undefined symbol: _ZNK13wxGLCanvasX1115IsShownOnScreenEv, version WXU_3.2
22:07:42: Error loading editor. Failed to load kiface library ‘/usr/lib/kicad/bin/_eeschema.kiface’.

Any ideas how to fix that?

I don’t run Ubuntu but from the message it looks like you don’t have the required version of wx something libraries.

Uninstall everything, remove the old 6.0 PPA if you still have it, add the 7.0 PPA, reinstall

Doesn’t change anything

Yes, it seems it has been linked to a another version of wxWidgets. But shouldn’t the builds in the Ubuntu PPA be build for exactly the specific version?

Do you have some custom version of wxWidgets installed from source or something like that?

2 Likes

I can’t help with Ubuntu, but for debugging you could find out what version of wx* it’s looking for by:

ldd /usr/lib/kicad/bin/_eeschema.kiface | grep wx

1 Like

Yes, thanks, that was the issue. At some point there was no wxWidgets 3.2 and had compiled it myself for some application. Since Ubuntu now has wxWidgets 3.2 that caused the problems. I deleted the the wxWidgets libraries from /usr/local/lib and now it works!

4 Likes

Thanks for the input…

➜ ldd /usr/lib/kicad/bin/_eeschema.kiface | grep wx

	libwx_gtk3u_gl-3.2.so.0 => /usr/local/lib/libwx_gtk3u_gl-3.2.so.0 (0x00007f7a0b51c000)
	libwx_gtk3u_aui-3.2.so.0 => /usr/local/lib/libwx_gtk3u_aui-3.2.so.0 (0x00007f7a0b472000)
	libwx_gtk3u_html-3.2.so.0 => /usr/local/lib/libwx_gtk3u_html-3.2.so.0 (0x00007f7a0b391000)
	libwx_gtk3u_core-3.2.so.0 => /usr/local/lib/libwx_gtk3u_core-3.2.so.0 (0x00007f7a0aac7000)
	libwx_baseu_net-3.2.so.0 => /usr/local/lib/libwx_baseu_net-3.2.so.0 (0x00007f7a0aa5f000)
	libwx_baseu-3.2.so.0 => /usr/local/lib/libwx_baseu-3.2.so.0 (0x00007f7a0a79c000)
	libwx_gtk3u_propgrid-3.2.so.0 => /usr/local/lib/libwx_gtk3u_propgrid-3.2.so.0 (0x00007f7a0a687000)
	libwx_baseu_xml-3.2.so.0 => /usr/local/lib/libwx_baseu_xml-3.2.so.0 (0x00007f7a0a672000)
	libwx_gtk3u_stc-3.2.so.0 => /usr/local/lib/libwx_gtk3u_stc-3.2.so.0 (0x00007f7a0a3ee000)

How do I interpret Kicad version? Focusing the wxWidgets it says that my system lib is wxWidgets 3.2 but Kicad was built with wxWidgets: 3.2.1. Is this correct? In this way, should I install 3.2.1 to make it work?

Libraries:
	wxWidgets 3.2

Platform: Ubuntu 22.10, 64 bit, Little endian, wxGTK, ubuntu, x11

Build Info:
	Date: Feb 14 2023 10:38:44
	wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24

I dont think I have custom wxWdigets

This is all I have now, and both packaged are being installed with Kicad.

~ …
➜ sudo apt search "libwxgtk3*" | grep installed    

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libwxgtk-gl3.2-1/kinetic,now 3.2.1+dfsg-4~bpo22.10+1 amd64 [installed,automatic]
libwxgtk3.2-1/kinetic,now 3.2.1+dfsg-4~bpo22.10+1 amd64 [installed,automatic]

Also, when I install Kicad

~ took 15.9s …
➜ sudo apt install kicad --reinstall
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  libwxgtk-gl3.2-1 libwxgtk3.2-1 python3-wxgtk4.0
Suggested packages:
  wx3.0-doc
The following NEW packages will be installed:
  kicad libwxgtk-gl3.2-1 libwxgtk3.2-1 python3-wxgtk4.0
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 48.2 MB of archives.
After this operation, 211 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y

It suggests wx3.0-doc, and this is a bit wrong since there is this wx3.2-doc available.

It looks to me like you do, because system-installed wxWidgets is usually not in /usr/local/

1 Like

Thanks, that indeed was the issue. I don’t recall having installed them because it was a long time ago. Those libs date from Jul 11, 2022. Doing what @Stefan-Olt did fix it for me. I removed manually all those outdated libs.

Here is the magic, if someone wants to copy and paste.

sudo rm -rf /usr/local/lib/libwx_*

Thanks @retiredfeline @craftyjon @Stefan-Olt

1 Like

The next issue I am seeing is this one :

image

Did you also build wxPython from source?

probably. in the past I was testing some things with wxwidgets and I may have compiled it myself since the current version at that time was not working or it was missing.

I installed on a clean system 22.04 of ppa kicad 7 works but creates two shortcuts and there are no language packs on win 10 everything is fine

This file /usr/share/applications/kicad.desktop is a symlink. You can delete it, and one of the Kicad icons will disappear. This is a workaround while they don’t fix it.

sudo rm -rf /usr/share/applications/kicad.desktop
1 Like