[Solved] Kicad_pro zombies accumulate until it freezes or crashes

I have an unusual bug that freezes or crashes my system. Kicad_pro v7.0.7leaves zombie processes upon exit IF I have opened the pcb. It doesn’t do it if the schematic is opened - only the pcb.

Here is my ps command output:

[ecomer@asrock ~]$ ps -elf|grep kicad
0 S ecomer     20680       1  4  80   0 - 499472 do_pol 11:30 ?       00:01:44 kicad /home/ecomer/Desktop/pureaero.mainboard/pureaero-mainboard.kicad_pro
0 S ecomer     21711       1  2  80   0 - 374605 do_pol 12:07 ?       00:00:08 kicad /home/ecomer/Desktop/pureaero.mainboard/pureaero-mainboard.kicad_pro
0 S ecomer     22073       1  6  80   0 - 374443 do_pol 12:11 ?       00:00:07 kicad /home/ecomer/Desktop/pureaero.mainboard/pureaero-mainboard.kicad_pro
0 S ecomer     22292       1 26  80   0 - 392909 do_pol 12:13 ?       00:00:06 kicad /home/ecomer/Desktop/pureaero.mainboard/pureaero-mainboard.kicad_pro
0 S ecomer     22380   16639  0  80   0 -  2302 pipe_r 12:13 pts/0    00:00:00 grep --colour=auto kicad

My Kicad software info:

Application: KiCad x86_64 on x86_64
Version: 7.0.7-7.0.7~ubuntu22.04.1, release build
	wxWidgets 3.2.1
	FreeType 2.11.1
	HarfBuzz 6.0.0
	FontConfig 2.13.1
	libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.16

Platform: Linux Mint 21.2, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: Aug 13 2023 23:14:49
	wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.74.0
	OCC: 7.5.2
	Curl: 7.88.1
	ngspice: 38
	Compiler: GCC 11.4.0 with C++ ABI 1016

Build settings:

My OS info:

Operating System: Linux Mint 21.2                 
Kernel: Linux 5.15.0-83-generic
Description:	Linux Mint 21.2
Release:	21.2
Codename:	victoria

NOTE: I also reported this as a bug. Link to BUG report

Just recently there was (is) a bug related to some problem with plugins, that aparantly uninstalled, did not uninstall properly. It may be related.

Yes, I confirm) at the moment it definitely doesn’t allow me to close the kikit plugin… What’s surprising is that I thought it was only a problem on win)

[SOLVED] Over on the kicad bug reporting gitlab “dsa-t” pointed me to python plugins being suspect. I removed all and then added back one at a time to identify the culprit. Kikit is the culprit. No more kikit and no more bug!
I’m unsure if I should close the issue because there must still be a defensive bug in kicad since a plugin shouldn’t be able to cripple kicad like this.

as an alternative to gerbtool

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.