[SOLVED] KiCAD 6.0 all the 3D models are not loaded

Solved. Read the suggestion by @themaninthesuitcase

I just installed the version 6.
I see there are several huge improvements.
I installed also the plugins via the plugin manager. I discovered it immediately

Although opening a recent project made with 5.1.12, it doesn’t find any 3D model. Now Im’ struggling with

I followed a suggestion by @paulvdh that said

but I checked it and although the dir exists and even the content, KiCAD doesn’t detect it


But all dirs and files are there, where they are supposed to be:

And when I open any PC project that has 3 D models, I get this

my own custom 3Dmodels are working fine. But they are very few (as you can guessing)

Where I’m wrong please?

I am looking at the Win32 error messages. Are you using 32 or 64 bit Windows?

@davidsrsb 64 bit. And I installed the 64 bit installer from the site

I’m under W 11 Pro 64 bit/

The 5.1.12 worked perfectly.


Anyone else using Windows 11 here?

@davidsrsb I think the problem is not about W 11. Due the fact that I was using KiCAD 5.1.12 perfectly under it.
Just with the update to the 6.0.0 I got this issue.

Ah important: (I think it’s better to say it again): my own 3D components, are loaded normally. They are the only ones visible.

MacOS same issue. You will probably want to add a path to the preferences: KISYS3DMOD should point to wherever KICAD6_3DMODEL_DIR points to.

1 Like

@davidsrsb I noticed that the variable suggested by @paulvdh is not declared on 6.0.0
Hence I created it from scratch right now.

The 3D objects are now visibile! Still the “32bit” error appearing. Which is strange since I did installed the 64bit

I think the package contain some error.


  • Once KiCAD 6.0.0 is installed, it asks to import all the settings from 5.1.12 but it doesn’t fully. I had to add manually my custom libraries
  • This variable is omitted. Probably they changed with the new one but there is some mismatch with previous projects
  • Probably the included VRML.DLL is 32bit and not 64 into the 64 bit installer


@hb020 while I was writing you posted :slight_smile: indeed. You’re right.

Although some other thing I highlighted, is still limping. I think a 6.0.1 urges …

1 Like

Nope, no issue here. tested the 6.0 installer even in a windows sandbox.

Was K:\KiCad the location of KiCad 5.1? If it was, and you installed 6.0 on top, you created a conflict.

@marekr yes I installed on top since it was told me that I could do it without issue

here the topic: https://forum.kicad.info/t/from-5-1-12-to-6-0-just-overwrite/32662

Now the point is: how to solve it.It’s not proposable to delete everything since I have all settings, custom libraries, scripts, plugins etc.

Delete just the bin folder and reinstall kicad in the same location.

1 Like

Heh actually found the bug here, the installer wasn’t set to erase the /bin/plugins folder.


@qu1ck thank you. Did it and solved it :slight_smile:
Thank you for the help

I have just installed Kicad 6.0 and I have a similar issue. I havew two separate folder, with Kicad 5.99 and Kicad 6.0. In Kicad 5.99, 3D models all work ok, but in Kicad 6.0 the default ones do not work. If I right click on them, they work, but they don’t work in the view on the entire PCB. What is the solution?


@Cezar_Chirila Check my answer above. You need to create a variable that on 6.0.0 was changed with another name and it doesn’t work on previous project.

@tormyvancool Unfortunately my problem is a separate one than yours. As I have upgraded from 5.99 (essentially 6.0 nightly - prerelease) there was no need to add any missing variables. I’ll dig and update if I can find a fix. As I have previously mentioned, strangely, if I check an individual part, the 3D renderer works, it is only broken when I try to view the entire PCB.

Later Edit: I am such an idiot. The “Toggle SMD 3D Models” was disabled by default. That fixed it. Sorry for causing any trouble.

1 Like

“Toggle SMD 3D Models”?

I also had this issue and it was fixed by adding the missing KISYS3DMOD to point to the same location as KICAD6_3DMODEL_DIR. I did at some point in the past download the updated zips from the git repo so I may still bump into some that are missing but so far so good on my 6.0 test project.

@themaninthesuitcase Indeed it’s exactly what I did to solve it (see previous comment wher I posted the screenshot). It has to be tackled because it is an issue.
Probably the old variable is contained into projects, hence opening them, we face out this issue. The new variable is valid for new projects only :-/

One PC where I had installed some of the recent 5.99, 6.0 rc1 and rc2 builds before release had no 3D path problems and included the old missed path
Another PC where I waited for the 6.0.0 before adding to 5.1.12 had the path missing