[SOLVED] KiCad 5.1.6 Install issues in Ubuntu 18.04

Hi,
I am running Ubuntu 18.04 in Virtualbox. I am trying to install KiCad and followed steps given here: https://kicad-pcb.org/download/ubuntu/

sudo add-apt-repository --yes ppa:kicad/kicad-5.1-releases
sudo apt update
sudo apt install --install-recommends kicad
# If you want demo projects
sudo apt install kicad-demos

But after doing this I am getting KiCad 4.0.7 installed in my ubuntu instead of 5.1.6.

Solution:
Earlier there was no PPA compiled for 18.04 but there was for 20.04 that’s why it was not working and installing old KiCad.
Now KiCad team has released 18.04 compiled PPA as well so now using same commands we can get latest KiCad Installed.

I don’t use Ubuntu much. Have you tried a visual installer like Synaptic to see what is going on? I know Debian took forever to update to the 5.X but I thought even they were in the 5’s now. Sounds like you’re getting the old defaults somehow.

Also, do a purge of the old. You might also want to look in your .config directory to make sure it is completely gone before trying again because there are some gotchas that you can check out in the FAQ section about upgrading from 4 to 5.

Did you have a clean new installation of Ubuntu where you added the ppa and installed kicad? Did you have another repository activated before ppa:kicad/…?

Can you link me to that FAQ? I also tried to install via Software Center but it also shows old version there.

Yes, it was freshly installed Ubuntu only and never installed KiCad. I followed those steps and got that older version itself.

There is a link to the FAQ section in the toolbar. It sounds as if your repository never got added. Check to see if it is listed in /etc/apt/sources.list .

I think it is getting added as I can see that PPA here.

But it looks like it’s not active (no tickmark)?

Yeah. I was just checking my system to see how they should look. On my system the little boxes turn blue when the repo is enabled.

I am getting this when I click on that. And it was this tick with Orange earlier. I just unchecked it to see if this makes a difference.

Maybe it’s time to go command line?

ls /etc/apt/sources.list.d/

What does it show?

This shows me

kicad-ubuntu-kicad-5_1-releases-bionic.list
kicad-ubuntu-kicad-5_1-releases-bionic.list.save

When you do sudo apt update, does it hit the kicad-5.1-releases repository?

Yes, Looks like it does as I am seeing this in result where it shows 5.1-releases.
Just now I uninstalled older version and trying to do this as a fresh installation.

Hit:1 http://in.archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://in.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:3 http://in.archive.ubuntu.com/ubuntu bionic-backports InRelease
Hit:4 http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu bionic InRelease
Get:5 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Fetched 88.7 kB in 1s (144 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.

What does apt show kicad show?

eelik:

Yes, This looks weird.

Package: kicad
Version: 4.0.7+dfsg1-1ubuntu2
Priority: optional
Section: universe/electronics
Origin: Ubuntu
Maintainer: Ubuntu Developers ubuntu-devel-discuss@lists.ubuntu.com
Original-Maintainer: Debian Electronics Team pkg-electronics-devel@lists.alioth.debian.org
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 57.3 MB
Depends: kicad-common (>= 4.0.7+dfsg1-1ubuntu2), python-wxgtk3.0 (>= 3.0.2.0+dfsg-7~), python (<< 2.8), python (>= 2.7~), python:any (<< 2.8), python:any (>= 2.7.5-5~), libboost-context1.65.1, libboost-system1.65.1, libboost-thread1.65.1, libc6 (>= 2.14), libcairo2 (>= 1.6.0), libcurl4 (>= 7.16.2), libgcc1 (>= 1:3.4), libgl1, libglew2.0 (>= 1.12.0), libglu1-mesa | libglu1, libgomp1 (>= 4.9), libpython2.7 (>= 2.7), libstdc++6 (>= 5.2), libwxbase3.0-0v5 (>= 3.0.4+dfsg), libwxgtk3.0-gtk3-0v5 (>= 3.0.4+dfsg)
Recommends: xsltproc
Suggests: extra-xdg-menus, kicad-doc-ca | kicad-doc-de | kicad-doc-en | kicad-doc-es | kicad-doc-fr | kicad-doc-it | kicad-doc-ja | kicad-doc-nl | kicad-doc-pl | kicad-doc-ru
Homepage: http://www.kicad-pcb.org
Download-Size: 13.1 MB
APT-Sources: http://in.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
Description: Electronic schematic and PCB design software
Kicad is a suite of programs for the creation of printed circuit boards.
It includes a schematic editor, a PCB layout tool, support tools and a
3D viewer to display a finished & fully populated PCB.
.
Kicad is made up of 5 main components:
.

  • kicad - project manager
  • eeschema - schematic editor
  • pcbnew - PCB editor
  • gerbview - GERBER viewer
  • cvpcb - footprint selector for components
    .
    Libraries:
  • Both eeschema and pcbnew have library managers and editors for their
    components and footprints
  • You can easily create, edit, delete and exchange library items
  • Documentation files can be associated with components, footprints and key
    words, allowing a fast search by function
  • Very large libraries are available for schematic components and footprints
  • Most components have corresponding 3D models

That’s definitely wrong. What’s the output if you do apt install kicad again?

It installs 4.0.7 version only.

How about apt show -a kicad, does it show both versions?

The repository http://ppa.launchpad.net/kicad/kicad-5.1-releases/ubuntu/pool/main/k/kicad/ contains packages starting kicad_5, not kicad-5.

Try

apt search kicad

also

apt install kicad_5