[SOLVED] KiCad 5.1.6 Install issues in Ubuntu 18.04

No, This shows only 4.0.7

Means instead of this

sudo apt install --install-recommends kicad

I try this command – correct?

sudo apt install --install-recommends kicad_5

At least you can try. I have focal so I can’t help you more on that, and the original kicad version is 5.1.5, so this may be different.

EDIT: try apt search kicad as was suggested.

This gives error

Unable to locate package kicad_5

Ah I see what your problem is. Look at the repository I gave the URL for. There are no packages for 18, only 19 and 20. Sorry you’ll have to upgrade Ubuntu or ask the maintainer to build for 18. Is there a reason you are not using 20, which is LTS?


Hi Keny,
Thank you for pointing this out to me. Let me update to 20.04 and try this out. I am using KiCad normally on windows only. But need to design some panels and for that one script kikit is not working out on windows this was the only reason I wanted to move to Ubuntu version.

I just noticed the same, but there still are packages -doc, -library… etc. That’s weird.

Thank you eelik and kenyapcomau for your help.
Conclusion:- To Install KiCad 5.1.6 we need to have ubuntu above 18.04.

At least for now. But we agree that there’s no reason to use Bionic, Focal works fine.

1 Like

I’m having the same problem. Seems odd to me that KiCad would no longer be packaged for 18.04, considering it is LTS. There are good reasons to still use 18.04, for example Xilinx Vivado is not yet supported on versions > 18.04.

Perhaps this is just an error?

The ubuntu ppa has been moved from js-reynaud to kicad-5.1. It is still maintained by js-reynaud but now is “official”.

The old ppa should still work for the 18.04 version.

Try this repo:
sudo add-apt-repository ppa:js-reynaud/kicad-5.1


Now I changed to 20.04 and the command given on KiCad download page worked. But somebody who still on 18.04 can try this out.

Thank you! got 5.1.6 installed on 18.04 from the ppa:js-reynaud/kicad-5.1 PPA

1 Like

Thanks you for pointing that. There is a missing compilation for 18.04. I’m fixing that :wink:

Hi there.
I installed Linux on Ubuntu last week for the purpose of creating a youtube on how to install it, it was a fresh install of Ubuntu and Kicad, everything worked perfectly fine, here is a screen shot of KiCad version.

Sorry, the quality of the photo was mot the best

Why don’t you use a screencast recording application?

I do, i just took a Photo with my phone for you, I have the video ready. Not yet uploaded, but you can see similar videos on my channel on you tube it is called Electromix electronics ideas

1 Like

Thank you Everybody for the support. As now there is fix for this question.
Can I mark this topic as a closed or Moderator has to do this?

You should be able to edit the title in the first post. But, you must tell us the fix first. :wink: