[SOLVED] How to permanently disable hardware acceleration for eeschema?

Hello!

I’ve installed the nightly build KiCad on Ubuntu 21.04 (x64) and during first run clicked to use hardware acceleration for it. Unfortunately, it seems to raise a bug as on the screenshot below:

I found it can be rolled back if I go Preferences > Preferences > Schematic editor > Display options and select the Fallback graphics as Rendering engine, but these changes are there only until the next start of eeschema. How to make them permanent?

Try Preferences -> Common -> User Interface -> Canvas scale.

2 Likes

Thanks! Needed to confirm the checkbox Automatic, the default value is 1.

KiCad not keeping the Fallback canvas seems to be a bug, though.

EDIT: reported in https://gitlab.com/kicad/code/kicad/-/issues/8436.

do you have an nvidia graphics card?

If I recall correctly, Ubuntu 21.04 defaults to wayland and classic xorg calls revert to software rendering via Xwayland

This is due to be addressed in the next beta series from nvidia (470… presently 465) as nvidia will provide hardware accelerated xorg calls as well as finally support GBM (not their EGLstreams…) as this will permit other wayland composite managers to work with nvidia since only GNOME and KDE support EGLstreams

I use X, not wayland. That’s not the problem, anyways. Pcbnew saves the changed canvas setting but eeschema doesn’t.

but what about the OP? not saving the settings is the bug though.

Confirm, 960M to be more precise.
But the issue is solved as stated above.

yup, an NVidia card,
so … assuming you are using Wayland that probably explains the initial visual issue since wxWidgets only support EGL in the development branch and thus 3.0.x will use X11 calls and thus will go via Xwayland (exposing this issue).

Obviously if you are using xorg instead then this theory is out of the window. Hopefully the 470 series of drivers will bring EGL support and hardware accelerated XWayland and thus permitting using the Modern toolbox.

I am holding off switching to Wayland until the 470 series

1 Like