[Solved] Horizontal green lines in every KiCad 6 application

Friends,

Be gentle, my first post. :slight_smile: Thanks a lot.

I tried to install new Kicad few times. It seems still see green lines after opening the main project file (extension: *.kicad_pcb). It used to work smoothly with earlier version of Kicad software but with new version not able to open the file to see it properly. It shows many green lines and not sure where the root source of the issue is. Tried to update the image itself (screenshot).

Application: KiCad (64-bit)
Version: (6.0.1), release build
Libraries:
wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11
Platform: Windows 10 (build 22000), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
Date: Jan 15 2022 13:36:27
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.78.0-DEV
ngspice: 35
Compiler: Visual C++ 1929 without C++ ABI
Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

Appreciate any input.

Thanks a lot.

Please provide version info (Help → About KiCad → Copy Version Info, and paste it here inside a code block).

This looks like a graphics driver issue; you can try updating your drivers.

1 Like

That is great dear gkeeth. Just added the version info. Thanks a ton.

Are you using the integrated GPU of an Intel CPU? This seems to be caused by a bug in outdated intel graphics drivers. Try downloading the current version for your hardware.

What hardware are you using? Is this a laptop or a desktop? Which CPU model? Do you also have a discrete GPU in your system?

1 Like

Please update your gpu drivers

I am having a same problem in my laptop which have a dedicated GPU RTX2060, CPU Specs:
Windows 11

Intel(R) Core(TM) i7-10750H CPU @ 2.60GHz

Base speed:	2.59 GHz
Sockets:	1
Cores:	6
Logical processors:	12
Virtualisation:	Enabled
L1 cache:	384 KB
L2 cache:	1.5 MB
L3 cache:	12.0 MB

Utilisation	4%
Speed	1.64 GHz
Up time	2:16:52:13
Processes	292
Threads	4031
Handles	144534
KiCAD Version Info:
Application: KiCad Schematic Editor (64-bit)

Version: (6.0.4), release build

Libraries:
	wxWidgets 3.1.5
	libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 22000), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: Mar 18 2022 03:04:44
	wxWidgets: 3.1.5 (wchar_t,wx containers)
	Boost: 1.76.0
	OCC: 7.6.0
	Curl: 7.78.0-DEV
	ngspice: 36
	Compiler: Visual C++ 1928 without C++ ABI

Build settings:
	KICAD_USE_OCC=ON
	KICAD_SPICE=ON```

That’s a NVIDIA display adaptor right? You probably should install the proprietary drivers, do a search for the NVIDIA download site.

SOLUTION:
Manually update graphics drivers, see this issue report at gitlab:

In preferences => Display Options => Rendering Engine => Fall Back Graphics.

Updating graphics drivers is usually the better solution.

This topic is becoming half a year old now, and the links to gitlab are now pointing to closed issues, so apart from updating graphics drivers you should also make sure you’re running the latest stable KiCad version