[Solved] Eeschema freeze when picking spice model library

Using Arch Linux.
I’m trying to get simulation up and running. I followed an Instrustables tutorial and the article on Woolsey Workshop on how to simulate, however whenever I pick a library for a model in the Spice Model Editor, Eeschema and KiCad freeze

Is your Arch completely up to date? What’s the KiCad version (and ngspice version)?

There was just someone having trouble with Manjero, which earlier in the thread someone indicated is based on Arch, that was just marked closed because an upgrade fixed it. That person wanted to uninstall the spice portion to fix their problem.

But finally they succeeded by upgrading, see Uninstall ngspice.

kicad 5.1.10-1
ngspice 34-2

I have updated kicad and ngspice to those versions but I still have the problem

So we have to figure out step by step what is going on.

Firstly we should verify that your installation (including ngspice) is up and running. I am not on Manjero, but openSUSE 15.2, but hopefully both installations look similar.

Please check if you have the examples available which are distributed by KiCad. They should be located in the directory
Go to directory laser_driver
Start eeschema
open the file laser_driver.sch
Check Tools -> Simulator
Run the simulation
Add signals for plotting V(/in) and V(/out) -> o.k.
and the plot is there (voltage versus time).

Please report if this action is o.k… We then might look for the next step.

Running the example simulation works fine.

Picking the spice lib in a new schematic still freezes the program.

That’s great.

Now we need to know what your current project looks like and what steps you performed until freeze.

Could you publish your project here (e.g. as a zipped file)?
What kind of device to attach a model do you have? Where did you get the model file?
Could you then describe your actions, step by step?

I seem to have figured it out.
Using the “Choose” button to open the file picker and load the lib freezes the program, but typing out the path to the file directly into the text field works.

Still I would be happy to get some more information how you managed to freeze Eeschema. The program should not freeze. There should not be a need to type a model library path into a text field.

I tell you how I would add a model library:
Double click onto the device symbol (symbol properties window pops up)
Edit Spice model (Spice Model Editor pops up)
Select File …
Choose a model file from the list (e.g. an OpAmp)
Choose a model from the list (if there are more than one model in the file)
Choose the type (Subcircuit for an OpAmp, Bipolar if BJT etc.)

and that’s it. Nothing freezes, everything is o.k.

What did you do? For example there is no “Choose” button in my action list.

Yeah, I meant the Select File button.

It appears to be a problem with Gnome, or the Nautilus file explorer. Switching to Plasma and picking the library with it’s default file explorer works fine.