[SOLVED] Accelerated graphics crash with multi monitor set up

Just so know, my problem now is no restart or reboot or anything makes kicad work on secound screen now. When I use accelerated graphics.

Is it possible to forse kicad to open new windows only on main screen? Then I can move it to second screen. That works. Just when it open a window direct on second screen it kicad freeze up.

This has to be a issuie with kicad. Becouse it works on second screen if it created on main screen and moved to second screen.

So it has to be some strange things going on when it create window and initialize OpenGL on second screen.

in the win settings there are two modes for connecting a second monitor in the first it is a continuation of the desktop in the second it is a duplicate of the first monitor try switching the mode

Yes it work when I switch to one monitor. Left or right is working and also cloning but that’s not really helps me and when I swich back to dual screen desktop the problem is as before.

I tried to reinstall kicad. I deleted all traces of kicad in the system. But no luck.

Reinstalled new driver for the RTX 3060, no luck.

I also uninstalled nvidia drivers for the RTX 3060 and tested to use the internal intel cpu graphics (yes I have dual screen on motherboard). But still it did not work with dual screen in kicad accelerated graphics.

So it’s NOT the graphics driver. It’s something with kicad that is unsynk windows handling of the dual screens.

I will take home the computer and test with the screens I have at home. Will be interesting.

1 Like

@Laserclaes When kicad freezes (and not crashes).

Open Task Manager, right click on Kicad.exe in the Details and select “Create dump file”.
Upload this dump file somewhere like google drive/ dropbox/ wherever (it’s a big file sometimes) and please PM me the link.

ok, test on screens at home. Same problem. I made a dump file now. I will PM you a link from “sprend”

Ahhhh… I don’t know how so send PM here in kicad forum.

But here are the link of the dump file. Only for MAREKR! All other please don’t download at this time. btw it’s 1.2GB

Hi @Laserclaes I removed the link as Marekr has a copy and RaptorUK has shown how to Message (PM).

Click on marekr’s Avatar then click Message . . .


1 Like

EDIT by JMK to remove @Laserclaes project link.

Yea you should do a direct message next time.

Anyway I downloaded a copy. Will look at it later tonight.

This may be related to this issue

I don’t see the Message button. Firefox?

New users can’t send PMs, but can receive them. So @marekr or whoever wants to contact a new user directly should initiate the conversation

1 Like

Uninstall from your PC, any audio crapware (it’s almost malware) called Nahimic. It’s common for ASUS and MSI, both also sometimes pre-built PCs too.

That software tries to inject itself almost maliciously into every software on your PC, in the process it ■■■■■ up OpenGL because it’s horrible incompetent software. It doesn’t even have any business interacting with OpenGL but it does.

This is a known issue affecting many programs beyond kicad.


WOW!!! I think you are right. Did a fast test and kill the processes and it seams to work. Have to digg a little diper. But Thx so far :slight_smile:

This will be some hacking… :wink:


1 Like

marekr already posted he has downloaded your file. So you can both edit your post to remove the link, and remove it from that “spread” website :slight_smile:


You have almost read enough to self promote yourself to “Basic”, which will allow you to message.

Left click your forum name then left click your forum name in the newly opened box then click “Summary”.
Compare your stats to these in the FAQ link here.

All you now need to do now is open and read a few posts in three more topics,

I also removed both links in this thread to your dump file.

A change was pushed to both nighies and 7.0 testing builds that’ll attempt to use a 'hidden method" in the nahimic malware that dissuades it from trying to interfere with the process.

We have gotten a quite a few bug reports due to this crapware being bundled by motherboard vendors and even some oems like Alienware and Lenovo the past year or so. It seems discontinued as the company was acquired by SteelSeries, but they also have a new product that boasts the data mining software that they promise enhances your audio, lmao


It’s still working fine over here. I have not tested the test builds. Still on 7.0.7. All I did was kill all processes of nahimic and uninstall some audio softwares. But still it’s NahimiServices.exe poping up in the processmanager but as for now. It all works. Will try harder to get rid of all nahimic BS.

Thx very much for the support of this. You saved my day!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.