Simulation not included on Fedora 29?


#1

I installed the Kicad 5.0.2 from the Fedora repos (out of the Software Utility).

When I looked up the Simulation in the Tools menu, could not fine one. Now, it appears that the build did not have SPICE enabled. If I go to the Help–>About Kicad–> Press the Version Info button, I see the following content:
Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=OFF
KICAD_SCRIPTING_MODULES=OFF
KICAD_SCRIPTING_WXPYTHON=OFF
KICAD_SCRIPTING_ACTION_MENU=OFF
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=OFF

Now, where can I get the RMPS built with the SPICE simulation included?

An even shorter procedure would be to download ngspice and somehow integrate it into the existing installation.

Please help

Thanks in advance
Rahul


#2

@SteveFalco might be able to shed some insight here. Probably has to do with the Fedora dependencies not building the libngspice shared library


#3

Unfortunately, there is no ngspice library available for KiCad to link with on Fedora. Yes, Fedora has ngspice, but sadly, no library.

@aimylios has a Copr repository here: https://copr.fedorainfracloud.org/coprs/aimylios/kicad-nightly/

If you install from his repo, you will get ngspice and scripting support, as he has privately built the missing pieces. Please follow his detailed instructions as to how to do the installation, because you must remove one or more python packages before installing his version.

Steve

#4

Thank you @Seth_h, @SteveFalco and @aimylios

I took the easier path. KiCAD on Ubuntu Bionic VirtualBox.

Suggestion: Is it possible that the absence of NgSpice can be explicitly documented on the Fedora 29 Installer/download page?

Thanks again
Rahul


#5

I don’t think we need to do that as we are simply waiting for upstream to update. It looks like the maintainer is happy with ngspice version 30.

See https://bugzilla.redhat.com/show_bug.cgi?id=1440904 and
https://src.fedoraproject.org/rpms/ngspice/c/5ab3e8c7a62e329ce31830189e0f6545ee375c8b?branch=master

When you get a change to check this, please update the packaging scripts @SteveFalco or @aimylios. Thank you.

I guess we need to add libngspice and libngspice-devel to be able to enable ngspice.


#6

That does look promising. I’ll try to take a look tomorrow.


#7

I managed to build it myself by enabling the updates-testing repo for my mock filesystem (/etc/mock/fedora-29-x86_64.cfg) and adding libngspice & libngspice-devel as dependencies in kicad.spec.template so that they get installed and used in the mock filesystem during the build. You can find the RPM I built here: https://github.com/gralco/kicad/releases/download/5.0.2-fc29-x86_64-spice/kicad-5.0.2-1.fc29.x86_64.rpm

If you already have KiCad 5.0.2 installed then just run “sudo dnf reinstall {path-to-rpm}/kicad-5.0.2-1.fc29.x86_64.rpm”

Hopefully KiCad will add support for Xyce soon.