Simulation Kicad

Errors when running the simulation
warning, can’t find model lm741
Circuit: KiCad schematic
**Error on line 13 :emphasized text
qu1 nc_01 net-r1-pad1 net-c1-pad1 net-u1-pad4 nc_02 net-r2-pad1 net-u1-pad7 nc_03 lm741
could not find a valid modelname
Background thread stopped with timeout = 0
Error: circuit not parsed.

Probably your lm741 model is not instantiated correctly.

Please have a look at how to attach an OpAmp model to a symbol.

tried attaching the diode (D1N4148) but getting errors
tried adding .model D1N4148 D to text but still finding errors
the error code
warning, can’t find model diode
warning, can’t find model diode
warning, can’t find model diode
Circuit: KiCad schematic
Error: unknown subckt: xd1 0 net-d1-pad2 d1n4148
Note: can’t find init file.

**** ngspice-32 shared library**
**** Creation Date: Fri Jul 10 12:37:34 UTC 2020**

Error: there aren’t any circuits loaded.

The diode model should be attached like the bipolar model from the example at

Don’t select a subcircuit model for the diode (as the message Error: unknown subckt: xd1 0 net- d1-pad2 d1n4148 tells me), but select type ‘diode’, because you want to load ‘.model name D’, but not ‘.subcircuit …’

1 Like

A little off topic, but this is a friendly reminder of a little bit of netiquette:

When posting screenshots, remember to only provide at most the window of the program or dialog box in question or just the area of interest. This will create a smaller image file that can be easier to read in a thumbnail (scaled down) size, and is less downloading especially for people with metered internet service. Additionally, you don’t have to make sure that there isn’t anything potentially embarrassing in the unimportant parts of the screenshot. As a real example from this site, someone posted a full screenshot completely forgetting that the parts of their desktop had porn video icons visible… (They corrected their mistake quickly, but the damage was done. Because this site provides a change history, one can find the original image if one tries.)

Check your screenshot tool to see if it supports selective or window-only snapping. If not, crop the image before uploading. (FWIW, I use Greenshot and it does support window-only and selected area screenshots.)

Solved it…Thanks though