Simulating Non-Inverting operational amplifier with Integrated Simulator

Hi everyone!

My name’s Igor and I am a new user of Kicad and its integrated Simulator.

I’m trying to simulate this circuit:

I took it from the demo simulation example called laser_driver and I did some modifications.

The ugly thing is that when I try to simulate I obtain this: (next post)

As you can see, I can not amplify the signal, in fact I am reducing it! Where is the problem?? I am using Kicad on Mac Os X High Sierra.

Thank you very much!

Here the simulation…

I have not used an op-amp for years, but why not in to V+ and net R3-R1 to V-?

Hi Pedro,

Thanks for the answer! I have just made changes you suggested. Here the simulation:

Is that correct?

See if this helps.
edit: Should have added @mifi


Thanks for that, hermit!
The strange thing is that I did not modify anything from pspice properties of any components from the laser_driver example, just remove some of them and change resistors’ values… I mean, I have respected pins for the op amp, included power supply pins…

I will research a little bit more… If anyone need more information of this test that I am doing, just ask and I will provide!

Try reducing the resistor values while maintaining the ratios, for instance:
R1 = 100R

For non inverting opamp your positive in must be connected to the pulse gen, your negative in should be connected to the resistor network. I.e., swap your pin 1 and 2.

1 Like

I believe he has done that already, just didn’t post the new schematic.

Yes, I have already done, but thanks :slight_smile:

I have just done it and this is what I get:

The output signal is a bit delayed but not amplified…

I just tried similar thing and it works ok for me. Here is my schematic file: laser_driver.sch (4.9 KB)

And output from simulation:

Could you post a screenshot of your schematic for reference?

Thanks for it, jcyrax!

This is really annoying because I have just download your .sch and I cannot obtain the same simulation! Maybe ad8009.lib is not correct for me??

Here is schematic:

I have just uploaded my project, maybe anyone can see errors or something… Thanks in advance!

OK, here is my whole project directory: laser_driver.rar (7.1 KB)

Thank you, jcyrax. I have just tested it and… again same simulation… really really strange. I am using Kicad Nightly Development Build: kicad-20171217-032952.845ca5f-c4osx.dmg

Do I need anything else to run this simulation correctly? I have tried other circuits and it was OK… I am really stucked… Maybe OSX is the problem?

Yes, strange. I tried your project and it work fine. Also, I am running later debug version:
Version: (2017-12-23 revision b05a40e)-master, debug build

Thank you for your support, I will try in my other laptop with Ubuntu and I will comment

Really bad news. I downloaded jcyrax provided project and same simulation in Ubuntu with this version info:

Application: kicad
Version: no-vcs-found-b05a40e~61~ubuntu16.04.1, release build
    wxWidgets 3.0.2
    libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-83-generic i686, 32 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.58.0
    Curl: 7.47.0
    Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:

Maybe is there any option in the software that I have changed?