Schematic Symbols disappear all the time (KiCad unusable)

Hi, I’m new to KiCad, have previous experience with Eagle and played with Altium for a while. I have a very annoying bug, which is a complete showstopper for me and makes software unusable.

Details: I use SamacSys library with library loader to import parts from mouser. So when the part zip is downloaded, it is automatically integrated into KiCad and I can place the component in the schematic right away from SamacSys library.

Once I place the component(s), in 5-10 minutes all my components disappear and become double question marks. ALL of them (well, all two for now). If I go to their properties (“E”), the library is there, it’s hooked up. If I manually select the library again, it doesn’t fix the issue. The only solution is to delete that part from the schematic and add it again. Until it disappears 5 minutes later again.

I googled everything I could, and everyone says it’s a problem with a library (thanks captain obvious), but there is no solution to it anywhere, and the software becomes pretty much unusable (and I REALLY don’t want to go back to Eagle, it’s ugly beyond description). I tried to restart KiCad and PC, didn’t change anything. Is there a way to make sure the components stop disappearing?

I have created the symbols on my second monitor before I wrote this very text. As I’m writing it here, both symbols on the second monitor are already just ??

Tech details:
KiCad 5.1.6
Library Loader 2.44
Windows 10

Firstly SamacSys library is third party and nothing to do with KiCad.
My first suspicion is that your zipped library is being opened by Windows, but not actually exploded to disk, so when the memory cache ages out it vanishes. Is the unzipped library on the disk?
What is the path you are saving this library to?

Why are you using an old release, 5.1.10 is the current stable?

1 Like

The FAQ section of this forum has a good tutorial of how the library system works.

But if you can place schematic symbols in the schematic then the libraries must already be added to the sym-lib-table file correctly, and what davidrsb wrote seems a likely cause of it breaking again.

This way of working with libraries is not the best, and it has already been changed in KiCad-nightly V5.99. In the new way copies of the library symbols are embedded into the schematic file, so they can’t get lost again.

Can’t say where the library is, I never had anything like that with Eagle. I just download, there is a popup that “hey it downloaded” from the library loader, and I can use it right away. I do the same with KiCad.

I have to admit, your logic that once the cache clears it vanishes, makes sense to me (IT guy here). That may be the reason. I will try to extract all zips that I download. (Again, Eagle never required anything like that).

I don’t have any specific path, I just run it all default settings.

As for program version, I have downloaded it not long ago, and it looks like there is no auto-updater, and I didn’t really care to check the website for updates. Will do it.

UPDATE: installed version 5.99 (nightly build), problem solved. Looks like it was indeed about how kicad handles libraries and zip caches. Problem solved. Thank you everyone for your input!

1 Like

May advice (also changed from eagle): If you just started with Kicad: go directly with the v5.99 nightly versions.

1 Like

On Windows you can just download 5.1.10 from the KiCad website and install on top.
One reason I asked about libraries is because you should not install custom libraries in the KiCad directory or they will be erased on any software update.
We recommend installing custom libraries under your own user - documents directory

You have something like this in your Library Loader settings:


And you of course have that directory in your file system:


Then you must have added the .lib library into your library table (here it’s in a project’s table):

If you can add a symbol from the library, then the library file should be OK. But the Library Loader can update the library automatically, so could it be possible that it somehow steals the library file and KiCad can’t see it anymore? What happens if you disable the Loader so that it’s not running at all, then quit KiCad and start and load the project again? Does the problem persist?

You could also try adding your own “cache”. Just copy the whole samacsys (or whatever) library folder to another location and point KiCad there instead of that Loader governed library. Does it help?

You should also check the permissions of the library file.

In this case it may not be the best option because 5.99 requires migrating the old schematic libraries to the new format manually. As far as I can see samacsys doesn’t support the new format yet. At least the user should first learn how the KiCad library system works and get rid of the original problem.

1 Like

Indeed, if I download a new component with the help of the Loader, the old one is replaced by the question marks in the schematic. Saving and reopening the schematic helps for me.

Well diagnosed! I’d not considered this case.

But it’s not the problem here. If the user follows the Loader instructions, the library will be just a normal KiCad library in the file system. If my guess is correct, the Loader watches continually the Downloads folder to see if certain kind of file is dowloaded, then it appends the libraries to the dedicated folder. The problem is most probably that the Loader does something to the file which KiCad can’t handle. Maybe it opens it and doesn’t let it go immediately, so KiCad can’t read it?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.