Schematic freezes when opened from KiCad, but not from eeschema


On MacOS, I have an important schematic that I’ve been working on and have saved periodically.

I quit KiCad normally without any apparent problems. There was no crash - I just quit it as usual.

When I reopen the project, KiCad opens and shows the project hierarchy.

When I click on the schematic editor icon, eeschema opens the schematic but then immediately freezes - I get the MacOS spinning wait cursor and I have to force-quit KiCad.

If I then double click the .sch file, the schematic opens directly in eeschema and appears to be OK.

Opening a previous copy of the project folder that used to work exhibits the same freezing behavior.

But opening a different project works.

Very frustrating…I now question the integrity of my files. The .pro file appears to be fine in a text editor.

What to do? Continue editing in eeschema, but then what?

Application: KiCad
Version: (5.1.6-0), release build
wxWidgets 3.0.4
libcurl/7.54.0 LibreSSL/2.0.20 zlib/1.2.11 nghttp2/1.24.0
Platform: macOS High Sierra Version 10.13.6 (Build 17G6030), 64 bit, Little endian, wxMac
Build Info:
wxWidgets: 3.0.4 (wchar_t,STL containers,compatible with 2.8)
Boost: 1.72.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.54.0
Compiler: Clang 9.0.0 with C++ ABI 1002
Build settings:

First: when bugs are suspected, always include full version info from:
** Help / About KiCad / Copy Version Info** and then paste that to you post. You can edit your post by clicking on the pencil icon at the bottom of your original post.

Where do you double click the file? Is that in KiCad’s project manager, or in a regular file browser from your OS?

Is there a possibility that you have 2 versions of this file on your PC?
All other files with KiCad are also readable ASCII, and can be viewed in a text editor, or compared with text diff tools.

There seem to be relatively many errors with the Mac’s this week. I use Linux myself, can’t help much with mac.

First, thanks for your reply, I appreciate your taking the time.

I’ve added the version info to my initial post. This is the latest version that I can install under MacOS high-sierra, and I cannot upgrade the OS at this time. I’d be willing to do so on another computer if this is a know bug with a known solution and the new version would be known to help. Otherwise, I’d rather not.

Anyhow, I double-click the .sch file from the file system the schematic opens directly into eeschema, and that works. I get the same result if I first launch eeschema and then use the file menu to open the schematic - it works and appears to behave normally. I can make a minor change, save the schematic, and then reopen it in this manor.

The problem arises when I open KiCad (the project manager) or double-click the .pro file (which launches the project manager). The project window opens and all appears to be well. Launching eeschema from there opens the schematic file - but then I get the spinning wait cursor and I have to terminate the KiCad process (force-quit).

The project file is pretty small and looks reasonable in a text editor. The schematic file is large and I don’t relish the thought of trying to decode that just by looking. However, it does look reasonable in a text editor. No garbage characters that I can see when scrolling through from one end to the other.

I have a backup copy of the folder in a different path. I don’t see why KiCad would be confused by that. I tried open the different copies with the same result, even the ones that used to work.

Is there a .plist file somewhere that might be corrupt - I can’t find it. I might try moving the project folder over to a different user account to see if that does anything.

The program residing in the application folder appears to have the same dates as when it was installed. My user account doesn’t have permission to change that anyway, so a crash or some such should not have damaged the program itself.

The problem must be related to the data files. How do I check their integrity?

Linux is nice but ugly. I’m a Mac person. I’ll use Windoze if I have to. Yuck. My Mac works for me and cross-platform is a big draw to KiCad for me. I’d hope that this is a simple problem since the schematic itself seems to be OK.

When Eeschema is launched directly from your OS, it works in “standalone” mode which behaves differently from the normal way.
In the screenshot below, the “foreground” window is from a project, and the “background” window is in “standalone” mode and has two extra icons for creating a new schematic or opening a schematic.


I have not seen it before that a schematic can only be opened in “standalone” mode. It suggests that something is wrong with the project configuration.

Hemm. Thanks very much. I’ll guess I’ll keep hacking around. The project file itself is pretty simple, I suppose I could recreate it if I can import the schematic into the new project.

A simple thing you can try is to create a new empty project, then copy the schematic and pcb files into it.

I’m also curious if I can duplicate this behavior.
Are you willing to zip your project and upload it here?

(You can delete most of the schematic and PCB to make it smaller, as long as the bug is still present in the crippled project).

Thanks again. I might be able to upload a crippled version of the schematic, let me think about that a bit. Meanwhile, I’ll try creating an empty project.

The PCB is in a preliminary state - that is - only to the point of dropping some footprints a while back to get an idea of some component positioning. I’m sure there are a lot of inconsistencies between the schematic and the PCB at this point.

Is it safe to assume that state of the PCB is not playing into this problem?

You can easy test this yourself:

  1. Copy the project to another directory.
  2. Delete the PCB.
  3. Check if the problem persists.

Thanks for your encouragement.

I tried deleting the PCB file (didn’t make a difference) and various other things, such as opening the project from another user account. I eventually discovered that there is a preferences directory: ~/Library/Preferences/kicad.

If I remove that folder, the next launch of the project acts as if it’s the first time I’m running KiCad and I get a dialog asking if I want to copy the default libraries. I say yes, then all seems to be well thereafter. I can then launch my schematic from within the project manager, edit it, save it, quit KiCad and then restart and do it again without freezes.

Before this - my restored backup copies of the project led to the freeze as well. So then I assume that the library was not the issue.

I don’t know what preferences I have lost - it appears at first that board parameters are stored within the project file itself and that only user interface preferences have been lost.

So, this makes me feel as though I might be able to continue working on the schematic. Hopefully, I’ll not run into further issues when I get to working on the PCB in earnest.

I haven’t got back into it enough to know if my custom symbols and footprints are messed up (or anything else) but things appear to be OK at first glance.

Still - I call it a definite bug and an unpleasant failure and time waster - to have the program freeze in such a manor.

All that said, thanks to the KiCad team for this program. I know that it’s hard to perfect things.

I’ve used mutli-kilobuck CAD software that has been frustrating as well and not as easy to use as KiCad. The main difference is that since you pay all that money, big companies are somewhat obligated to help. That doesn’t make it any easier and often such problems go unsolved in the end, anyway.

Greetings, I’m replying to my reply, just to update…KiCad has been behaving well since I removed the preferences folder. Everything seems to be working again, at least up to editing footprints. I’ll be delving deeper into the PCB layout soon.

Greetings. This hang just happened to me again. After a fair amount of additional work without any problems, it just happened again. Here’s a summary:

Working normally, I quit PcbNew, Eeschema, and finally, the project manager in that order after a day’s worth of work. KiCad crashed after a few seconds when I closed the project manger. I then immediately tried to reopen the project…project manager opened. Opening the schematic from the project manager however - the schematic hung - just like before. Spinning wait cursor, I had to force-quit KiCad.

Then, I tried again. Project manager opened. I did not open the schematic, but started PcbNew from the project manager and that was fine. I did a normal exit - quit PcbNew, then the project manager.

Next, I opened the the schematic in stand-alone mode. It came up without problems - just like what I’d seen last month. I was then preparing to delete my preferences again since this is what fixed it last time.

But instead, I gave it one more try opening the project - fully expecting the schematic to hang again. This time EeSchema did not hang and everything seemed to be OK. I quit and restarted everything several times.

I suspect that this is all coming back to the preferences becoming corrupted somehow when quitting KiCad.

FYI. David Or Dave.

Please update to 5.1.9. There is a stack of crash fixes.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.