Reversed symbol when added

Hello !

I’m a new user of KiCad (currently using the version 6)

I have an issue with an imported symbol from SnapEDA. The symbol is correct in the selection panel, but when I add it, it’s reversed. I tried flipping it, checking configurations and all, but I didn’t find anything to help.

Does someone have an idea or a solution ?

Thank you and have a nice day,

I have never seen mirrored text in the schematic editor before and am mostly guessing…

I suggest to load the symbol in a text editor and then compare it with some other symbol.
The text below is from loading a simple resistor symbol in the symbol editor, then [Ctrl + A] to select it all, [Ctrl + C] to copy it into the clipboard, and then pasted in a text editor (or in this post).

(symbol "R" (pin_numbers hide) (pin_names (offset 0)) (in_bom yes) (on_board yes)
  (property "Reference" "R6" (id 0) (at -2.54 0 90)
    (effects (font (size 1.27 1.27)))
  (property "Value" "2M7" (id 1) (at 0 0 90)
    (effects (font (size 1.27 1.27)))
  (property "Footprint" "Resistors_THT:R_Axial_DIN0309_L9.0mm_D3.2mm_P12.70mm_Horizontal" (id 2) (at -1.778 0 90)
    (effects (font (size 1.27 1.27)) hide)
  (property "Datasheet" "" (id 3) (at 0 0 0)
    (effects (font (size 1.27 1.27)) hide)
  (property "ki_fp_filters" "R_* R_*" (id 4) (at 0 0 0)
    (effects (font (size 1.27 1.27)) hide)
  (symbol "R_0_1"
    (rectangle (start -1.016 -2.54) (end 1.016 2.54)
      (stroke (width 0.254) (type default) (color 0 0 0 0))
      (fill (type none))
  (symbol "R_1_1"
    (pin passive line (at 0 3.81 270) (length 1.27)
      (name "~" (effects (font (size 1.27 1.27))))
      (number "1" (effects (font (size 1.27 1.27))))
    (pin passive line (at 0 -3.81 90) (length 1.27)
      (name "~" (effects (font (size 1.27 1.27))))
      (number "2" (effects (font (size 1.27 1.27))))

Can the pins on the imported symbol be deleted and replaced with Kicad pins?

Just a guess, I’ve never imported symbols… quicker and easier to make my own… and they always work.

This issue was reported a week back: Imported Schematic Symbol is reversed in the EESchema (#13007) · Issues · KiCad / KiCad Source Code / kicad · GitLab

It seems it’s SnapEDA’s fault. They may have fixed it, if the comment is correct so try downloading the symbol again.


Thank you. I’m gonna look into that !

I’m going to follow the response from the issues retiredfeline gave me. Thank you for your suggestion ! Based on the issue, I will probably need to modify the model manually too.

Thanks all :slight_smile:

Hi Syb and everyone!

I wanted to give you an update here. We have manually updated the KiCad file for the ACJC6V part. This is now converting properly.

After some investigation, we found that KiCad does not support mirrored text in the schematic as it was indicated in the documentation here. Our software team is currently working on updating our converters to avoid this instance for all parts moving forward.

Thanks again for bringing this up and if anything else comes up with a model from SnapEDA, please feel free to contact us, we are happy to help.

Ana Trujillo from the SnapEDA team.


I just have to ask… When would anyone want to have mirrored text in a schematic? I’ve tried, but I cannot come up with a use case for a mirrored text in a schematic.


Thank you ! It does work now.

Have a nice day,

1 Like

Hi Albin!

This is a good question, thank you for bringing it up.

We don’t actually use mirrored text in the symbol in KiCad. However, in some cases like this one, we use the mirror option in our base format to justify the texts between left and right. This is why, when the symbol is converted to KiCad, the pin names are getting mirrored.

For more insights, based on the documentation from KiCad, mirrored text justification is supported in the symbol editor. Nevertheless, this is not the case for the schematic. To avoid this, we are updating our exporter to recognize these cases during the conversion.

Please let me know if this clarifies your question, we are happy to help.

Ana Trujillo from the SnapEDA team.


You made me to search what SnapEDA is. I have never heard before. I’m used to define all my symbols and footprints myself and since I moved to KiCad in 2017 I also define 3D models if there is no in KiCad library.

You can also use which have a lot of components too

I am very happy that SnapEDA are fixing this at their end. Chasing “unexpected” corner cases in KiCAD code is never the best idea

Hi everyone!

I wanted to give you all an update here. We have now updated our exporter to avoid the mirroring in the symbol when being placed in the schematic. This now applies to any symbol downloaded from SnapEDA.

Thanks again to everyone for reporting this and if anything else comes up, please feel free to contact us.

Have a great day!
Ana Trujillo from the SnapEDA team.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.