Reconfiguring the Eeschema GUI, compiling from source


#1

Hi,
I was wondering if it was possible to create just the Eeschema editor from source code in order to configure it for a specific project.
Thank you.


#2

This seems to be the same question you have asked before. If you build KiCad, it also builds a standalone eeschema, which sounds like what you are looking for.


#3

It is slightly different from the previous question, but yes, it is under the same premise. Do you have any advice with building kicad from the source code, other than the instructions provided here http://docs.kicad-pcb.org/doxygen/md_Documentation_development_compiling.html ?
Thank you!


#4

I guess my advice is:

  • Read the instructions carefully
  • Don’t be too discouraged when they don’t work :slight_smile: Usually there is something simple to fix it, but not always…

#5

Okay. Thank you again!


#6

Could someone who actually followed all the instructions from that page tell us how long it took and how many times you ran into “issues”

John Eaton


#7

Personally I spend like 3 weeks trying to get it compiled.
Then I invited ones of the packagers to a party at my house, and the day after it compiled perfectly. Highly recommended


#8

The experience will vary a lot depending on what OS and version you are compiling on, as well as experience with build tools. On Windows it took me several days to get working and probably 3-4 issues. Now it is set up, I build from latest source usually with no issues, but I don’t build OCE support.


#9

Did you follow the instructions from the kicad website?


#10

I followed the instructions as they were at the time, but they get out of date and change due to new requirements. I haven’t set up a new build from scratch using “todays” instructions with “todays” source code, probably no one has. That is why building KiCad is often a bit of a pioneering activity.

There are many threads on building KiCad for various platforms, I guess most people build without issue and only post here when they have problems.

I guess people ask because they want to know whether they will waste time trying to build KiCad, but really that is impossible to predict. I would say set aside 4-6 hours and see how far you get. If you have never used a DOS or Unix command window it might take longer…


#11

Thank you. Do you have any tips on how to get started if I wanted to build kicad and only eeschema on Windows?


#12

I’m no CMake expert, but I think if you comment out the “add_subdirectory” lines for the items you don’t want in CMakeLists.txt it might work. There may be some dependency issues.


#13

I gave up on building it on OSX, not because KiCAD is difficult to build - but I couldn’t get wxWidgets to build to have one configured correctly for KiCAD. It runs into all kinds of problems like missing system includes.


#14

Following the instructions on the website, I could compile the source files. However, when I run the kicad.exe, I encounter the following errors: “The code execution cannot proceed because libwinpthread-1.dll was not found” and “libgcc_s_eh-1.dll” was not found. Would anyone have any idea how to solve this?


#15

You must execute the executables from the msys shell. If you want to run the executables without the shell, you have to go through the process of copying all the required files from msys to the same folder as the exes.


#16

I haven’t seen that problem. Did you move kicad.exe ?

I can run kicad.exe outside of the msys shell, just by double clicking on it in Windows Explorer, I haven’t encountered any problems like that. (WIn7/64).


#17

No, I didn’t move kicad! It is in the folder “C:\msys32\home\kicad-source\build\release\kicad”, which is where it is built. I am using Windows 10, though.


#18

When I run the executable using the msys2 shell, I receive the following error “C:/msys32/home/kicad-source/build/release/kicad/kicad.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory”


#19

Hmm, maybe 32/64 bit thing?


#20

Ahh! You’re right. I had to run the executable using the 64 bit command prompt :slight_smile: