Protip: nicer via stitching


#21

OK; thanks. I succeeded in dragging a screen shot as you see here. I think that is with default canvas. This is all very strange as I am now getting inconsistent results. I am thinking that the exact sequence of clicks may be critical. It appears that even when it does work, I see no result until I move the mouse. This is the sort of way that different software can work differently in more ways than I would imagine. But it does seem to be similar now regardless of view…switch canvas to default or to openGL

Thanks again.


#22

BTW I want to thank the moderator for an excellent forum.

At this point I have loaded a very recent (Aug 01) version of the software (previously had May version.) This process was surprisingly easy and user friendly.

I do not know whether this is related but now with OpenGL, when I select a block of vias I am able to duplicate them etc. and this is far better than what I remember. It seems to me that before updating the software, I was getting inconsistent operation both with and without OpenGL but I cannot be certain.

If nothing else it would be great if someone could confirm any recent improvements to the software, particularly for duplicating a block of vias.


First PCB Layout
#23

Made a video to showcase this today. Really appreciate the writeup from @c4757p, I’m going to be using this all the time on boards now.


#24

I didn’t realize this was already on YouTube:

Hopefully me talking over my version added a little bit.


#25

Nice! That’s better than my video, for sure. I didn’t even have a microphone at the time :stuck_out_tongue:


#26

I like that you are making videos with previews of new features. That’s a really cool idea.


#27

Shhhhhhh! That video’s still unofficial! :wink:


#28

Uh…it’s listed on your user page…might want to unlist that :wink:


#29

I’m fine with it being seen, I just don’t want to blow the trumpets!


#30

So I just tried a variant on this that is similar to what I’m already doing for mounting holes. This solves the permanence problem if you change other footprints and allow deletion of old footprints on netlist import. Not as fast as the pure pcbnew option, but even more stable.

I generated an array of pads connected to the appropriate net in eeschema. I set them to my stitch via footprint and imported them into pcbnew and placed them like any other component. A little tedious to place the array of pads, but once it’s done, it’s done.


#31

I like that idea. It would be confusing if all of the via stitching disappeared after a secondary import.


#32

And I normally do a lot of secondary imports in the course of a layout. Schematic and footprint tweaks, and so on.

FWIW I already put mechanical features like mounting holes on the schematic and in cvpcb so they (re)import correctly and get connected to nets like GND. If they start cluttering the schematic page I shove them on to a second page.


Stitching ground planes with vias
#33

I didn’t see that anyone had mentioned this:

One problem noted with this method of via stitching is that the stitches get removed if you re-import the netlist. I found the way to fix this is to select the stitch vias and lock their footprints. Then they can’t be removed by accident.


#34

This has been brought up a few times. That works, or just don’t select Delete Extra Footprints. I didn’t realize anybody actually used that… I just remove footprints manually.


#35

The method I describe does not lose stitch vias on import, but has the somewhat cumbersome need to add the vias as a component to the schematic. This is not a very big probelm as I make one and copy/paste blocks until I have more than enough. I delete the excess vias as part of final clean up.


#36

@c4757p @ChrisGammell Kindly upload videos on Vimeo as well. It is hard to get Youtube running on my computer. Viemo is free too. :mega:


#37

Hey guys,

Just tried out this trick and it works well, but I have an issue with annular rings on all the layers. If I want to connect something from layer 2 and 3 on a 4 layer board, it creates an annular ring on the top and bottom layers for now good reason.

Is there a way to to turn this off? Poked around, but didn’t see anything.


#38

I see your stitching vias don’t show the reference value when placed in pcbnew. I’ve set reference to invisible both in footprint editor and confirmed it’s invisible in pcbnew. But it won’t go away?


#39

Same problem here, using stable 4.0.0.
They don’t appear until i restart pcbnew.


#40

You saying you want them to appear when invisible? I want them to disappear.

Edit: I had the “Hidden text” option chosen under “Render” tab.