Problem with zones and thermal reliefs

Hello, I’m laying a new board and I’m having problem with zones and thermal reliefs.

Until now this feature had work great for me however, using the following footprint from the library:

Package_DFN_QFN:Texas_S-PWQFN-N24_EP2.7x2.7mm_ThermalVias

I get something like this when using a zone to connect the pad of the footprint:

As you see, there is no connection between the GND pad and the GND zone and I dont understand why, even with very small clearances and widths:

Zooming in, I see a couple of bumps where normally the zone would connect to the pad, somehow exactly in front of the vias, but there is no connection.

Changing the zone “pad connections” to “Relief for PH only”

or solid:

does what I want however, in other parts of the board, I do not want a solid connection between the zone and the pad.

Maybe I have to make many GND zones with different settings ? Any ideas ?

EDIT:
Using different zones kind of works, because there are some strange artifacts on the corners of the zones:

KiCAD Version

Application: Pcbnew
Version: (5.1.5)-3, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.66.0 OpenSSL/1.1.1d (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.1.1) nghttp2/1.39.2
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.71.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.66.0
    Compiler: GCC 9.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Pictures 1 and 2: I cannot distiguish the colours properly, but it may be the footprint is on top layer while the zone is on bottom layer?

There is a pad in both layers (bottom top) and the zone is in the bottom layer, also, no hidden Edge.Cuts lines or similar :frowning:

if i remember correctly not too long ago someone pointed out that the algoritm that connects the thermal reliefs is not that smart. It could very well be the same root cause here. But i am not sure about it.

I did have a look around in the forums, but I couldn’t find something related to this, moreover, I have use this feature before in previous version and I do not remember such a problem.

I rewrote the zone fill algorithm for 6.0. If you get a chance I’d be interested in whether or not this works for you in the nightly version (5.99).

Just compiled Version: (5.99.0-873-g3cd143f8d), release build
Seems to behave as before. ‘der.ule’s’ millage may be different.

Thanks Jeff, I will try to test it on the weekend, I will use the same board to test.

You mean that it shows the same problem ?

Have not looked at the code yet, however those bumpy things are still there.

Try the footprint:
PWQFN24.kicad_mod (6.1 KB)
I’m not using nightlies. Didn’t checked but I hope it will work well with 5.1.5