Problem with simulating diodes


#1

Hi guys. I have a problem Kicad Spice. kicad spice diodes do not work. I get the “unknown parameter (diode)” error, even though I set up the circuit with the elements in the PSpice library. Thanks


Spice and KiCad
#2

I have not used spice yet, except for a single RC combination.
My first thought is some mismatch between schematic symbol and spice model.
Have you tried using the PN junction of a BJT as a diode, or another diode?

Before more knowledgable people react you may want to add all the information you can gather about the schematic symbols and spice models used, together with the full KiCad version info.


#3

KiCad spice diodes do work. Please have a look at the example coming with each KiCad installation, to be found in /demos/simulation/rectifier.


#4

I can confirm this.
I have not used KiCad V5.0.2 much yet but am also interested in the simulator.
I copied all demo’s examples from /usr/share/kicad/ to ~/projects/kicad/
Then I started the retifier project and ran it. This is what it looks like:


#5

The pspice library is from a time long before kicad supported simulation. I am not sure if its symbols are setup correctly to work with ngspice (hint: pspice is not the same as ngspice!)


#6

The problem you were having is that the pspice symbol calls your diode “DIODE” and doesn’t define the model for it. If you add the text:
.model DIODE D
somewhere on your schematic, then the simulation will run but it will use a very generic diode model with idealized parameters. Like @holger mentioned, it’s best to use the example schematic as a starting point.


#7

Thanks for answers. Problem has solved. I add model diode and succesfull simulation.