PCBNew Giving Parse Error

Trying to add a footprint in PCBNew today gave the following error:

PARSE_ERROR: Expecting ‘circle, rectangle, oval, or trapezoid’ in input/source ‘https://github.com/KiCad/Connect.pretty’ line 34 offset 14 from /build/kicad-I8aRie/kicad-4.0.6+e0/kicad/common/dsnlexer.cpp : Expecting() : line 369

It seems a rounded rectangle made it into the library.

I wonder, is there a Duty Emergency Librarian on call?

I guess there are thousands of Kicad user who are going to be encountering this problem.

Yup. Looks like it was reported, too, so should be fixed soon. I think they have a script that checks libs before allowing commits, so maybe it doesn’t check for this? I’ll prod Oliver about that the next time I run into him on IRC.

Reason #152325 why the Github libs are a horrible idea.

I think the idea behind it was well meaning, but the execution is problematic. People asked for a crowd-sourced library, that it is what they got, but I think all devs know that what users ask for often isn’t what they really want.

I can’t think of a fix that wouldn’t take a lot of new code, but I am thinking about it. If I can get a Kicad build environment going I might look at doing a git plugin.

At absolute least it should point at a verified branch, not master. The library system shouldn’t crash and burn because someone accidentally approved a commit they shouldn’t have. But the github library plugin doesn’t actually understand git, soooo…

Ideally Travis would load into Kicad and sanity check, that probably needs a command line option.

How can I run KiCad using only the local libraries I’ve downloaded.
I did a full update two days ago. Don’t need to tied to the internet all the time.

Use the Footprint Libraries Wizard (preferences menu) to load up all your local libs into the project configuration, and optionally into the global/system configuration as well.

Thanks, c4757p.
I did that… Made them globally accessible to all projects.
How do I tell KiCad to use only them and ignore Github ?

Delete the github libraries in the Footprint Libraries Manager.

Thanks, c4757p !
That worked. Parse error is bypassed, now.

The library has been fixed. You can add it to your fp-lib-table again.
In future there will be a automatic test that prevents bad footprints from ending up in the official library.