PCBNew: DRC fake errors and warnings?

On one of my project I already made with 6.0.11 and it was without errors and even manufactured without errors, once imported into the 7.0.0 I got the errors you see her and 109 warnings.

As I said: in the 6.0.11 not errors/warnings detected.
I manufactured already 32 PCBs and are perfectly working.

Now: why dos the 7.0.0 detecting these errors?
To any major update I have to expect tahta ll projects are screwed-up?


KiCAD version
Application: KiCad PCB Editor x64 on x64

Version: (7.0.0), release build

wxWidgets 3.2.1
FreeType 2.12.1
HarfBuzz 5.0.1
FontConfig 2.14.1
libcurl/7.83.1-DEV Schannel zlib/1.2.13

Platform: Windows 11 (build 22000), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Feb 12 2023 01:35:19
wxWidgets: 3.2.1 (wchar_t,wx containers)
Boost: 1.80.0
OCC: 7.6.2
Curl: 7.83.1-DEV
ngspice: 39
Compiler: Visual C++ 1934 without C++ ABI

Build settings:

I believe the text height constraint is new in 7.0.0 for work with a variety of fonts. The default value may be conservative, so if you know your manufacturer can make the board as is you can probably change the constraint value to the current text height without worry. You can also ignore that warning if you’ve already had the board built.

The library check errors might signify that the library provided footprint has changed. Again, if the existing footprint worked for you, you can safely ignore the warning.

yes I set-up now the character to 0.5.

I updated my message adding some screenshots because libraries are not changed (so far I know)
It’s screwing up all projects in this way.

What are the thermal relief violations? Since when there is this? I never see it before and all the PCBs I have made are working excellently and SMDs are correctly mounted

(Apologies if you already know this)
Thermal relief in general refers to ways of reducing contact between solderable pads/holes and large copper planes/zones that might make it hard to get the solder up to temperature for reflow. In this case I imagine KiCad is trying to add at least 2 spokes around a pad and can’t due to some other constraint. Maybe there is a trace of another net routed 270 degrees around a hole that should touch a zone and KiCad can only fit in one spoke to make them connected. The default zone constraints can be found in File > Board Setup > Constraints. You can (probably) safely change “Min thermal relief spoke count” to 1.

1 Like

In Board Setup → Constraints you can define the minimum spoke connections you want (4 is max).


We answered at the same time :smile:

1 Like

Depends. Not if you want a low-impedance or high-current connection to a plane.

1 Like

@straubm @scandey do you mean that KiCAD si detecting an error only because in this case it can put 3 spokes instead of 4? My settings is written 2 …

here again … it’s not a different net … it’s the same net. What it does it’s a disaster. It’s not workable in this way.

No, this is strange. Look at the error message: it says there is actual 1 connection, but there are 3.
In the moment I have no idea what happens there.

That does look rather suspicious to me. I just had a quick glance through the existing issues and I didn’t see anything similar, so it may be worth starting an issue on Gitlab (About KiCad > Report Bug) and uploading the project if possible. If you can’t upload the project publicly, there is an option for confidential bugs that only developers can see.

I do not see the solder mask here, but as this is a solder jumper it very well might bridge net …JP3-A and …JP3-B.
You can set this check to ignore in Board Setup → Violation Severity

[EDIT] Why is it checked in the first place? In high density professional boards quality policies often call for a soldermask between pads like so:


so this DFM (design for manfacturing) check was introduced. In my understanding, that is (I’m no dev).

1 Like

there is a solder jumper indeed. but on the 6.0.11 everything worked fine.

There are too many problems with the 7.0.0 for me, in this moment. It’s very critical to work with.
I did notice that:

when I move the lines of the Edge Cyut layer, it doesn’t appear any-longer the circle that indicates the 2 lines are correctly overlapping the vertexes

When you try to design a route, it doesn’t hang any-longer to the pad or the other route but to the center of the component

I can’t reopen the project so n 6.0.11 because now it’s saved under 7.0.0

Cannot confirm. Here they are there.

But I see where you are heading. Yes, there were many changes in UI, additional functions, additional checks. Whether they are perceived as enhancements or as detrimental lies - as so often - in the eye of the beholder.

the suggestion you gave to ignore the thermal relief: worked

thank you so much.

As for the snap points: are they enabled in the preferences (=set to ‘Always’)?

It is already to Always. But not always it appears that circle
The issue is: when the circle doesn’t appear, KiCAD is considering the 2 lines not coincident than the PCB Contour is broken …

For whatever it is worth, I couldn’t replicate either issue with a minimal example. Thermal relief spokes are being counted properly and I get a proper snap on the edge cuts lines. Not to say that these aren’t real bugs, just that they aren’t universal. I’d really suggest making issues for both of them with the project attached (since perhaps it may be related to the upgrade from 6.0.11 to 7.0.0?)

Application: KiCad PCB Editor x86_64 on x86_64

Version: (7.0.0-0), release build

	wxWidgets 3.2.1
	FreeType 2.12.1
	HarfBuzz 5.3.1
	FontConfig 2.14.0
	libcurl/7.86.0 SecureTransport (LibreSSL/3.3.6) zlib/1.2.11 nghttp2/1.47.0

Platform: macOS Ventura Version 13.2.1 (Build 22D68), 64 bit, Little endian, wxMac

Or @tormyvancool could send a project to me on PM. I am prepared to sign any NDA :wink:.
Honestly I do not think those are bugs but I can be wrong obviously. I remember I had something with those cycles myself and I solved it without bug report, but no idea how that went.

Please here what happens … and I used the most fine grid …

I had to re-design the arc. BUT even when I get that circle, on DRC I get error message.
It’s not workable this thing.

here the new arc…