PCB- Router Shove isn't as aggressive as before

Using Kicad 6.0.1 and trying to route a PCB. The interactive router will no longer shove vias and it won’t shove multiple traces to make room. It seems to only shove one trace at a time and it struggles with that.

Is there any settings besides the “Interactive Router Settings” I am missing that can’t get it back to how it was in Kicad ? Any other tips to help me out? Manually moving each trace to make run is a bit tedious


There is a bug report about this on GitLab

1 Like

Try the latest 6.0.x testing build to see if that helps. It can be found on kicad.org → download → OS → testing builds. At least for windows.

1 Like

It’s a known bug. Working to fix it. If you want to help, PM a board that shows it.


1 Like

Thanks, any help on finding this “board”?

Found these related posts:

tried the latest test build its better but still doesn’t move shove vias at all

A “board” is the same as a PCB layout.

Could you send the kicad_brd file with which you’re currently having these problems to twl in a private message? And point out by a screen shot or recording which area has these problems?

Found the solution in the other forum post. I decreased the hole to copper size, there is a bug there. It is treating the copper of the via as the hole and not allowing the push. I decreased the clearance for now. w

I still find it strange that you’re having these problems with 6.0.1 and not with the version you used before. Where you comming from 6.0.0 or 5.0.x?
Did the board pass DRC before you switched to 6.0.1?

Are you still in need for more example boards, even though decreasing the clearance solved the issue? I’m not at all sure how the router is supposed to work if there is a “collision” between two items (DRC due to them being closer than the set clearance). Maybe the fault is rather with sheldons clearance having changed when switching from one version to 6.0.1, then the router behaving differently?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.