PCB asks for a newer version than 5.1.6!

I have a problem.

For some reason related to some funny graphics acceleration problem, I used this version for a project.

Application: KiCad
Version: (5.99.0-1149-gba36fc000), release build
Libraries:
wxWidgets 3.0.4
libcurl/7.66.0 OpenSSL/1.1.1d (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.1.1) nghttp2/1.39.2
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
Build date: Mar 25 2020 22:01:43
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.71.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.66.0
Compiler: GCC 9.2.0 with C++ ABI 1013

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

Yesterday I upgraded to version 5.1.6 and trying to open a PCB project I got:

PCB_bug

Any way out of this?

This is the file:

charger_stepup.kicad_pcb (271.6 KB)

Thanks
H. Martins

You can try to remove the offending parts from the file manually with a text editor. Go to the line and offset and try to decipher what it means. But depending on the file there may be tens or hundreds of similar items, in which case you have to use some advanced find&replace functionality.

It would be possible to make a python or other script for this but I haven’t heard about any. The developers have explicitly told that backward conversion won’t be supported in KiCad itself.

You seem to be lucky; there are only 3 sections which have to be removed.

You might find that removing the stackup section and maybe changing the version to 5.1.6 with a good text editor (NOT Word) might be sufficient - I am away from my computer at the moment so can’t check.
The file format going forward will continue to change and even if there is a script that works now, it will probably break with the next format change.
You can run 5.99 alongside 5.1.6 so, depending on the risk you want to take, you might be able to finish your project in 5.99. As has been pointed out, the 5.99 versions are really just for testing and not for production.

‘Downgraded’ would fit better.

1 Like

7 posts were split to a new topic: Are there actually good reasons NOT to use the nightly builds?

Thank you eelik
Thank you everybody.

Indeed I removed the problematic parts and it opened with 5.1.6

Thank you once again.
H. Martins

3 posts were split to a new topic: My plugins do not work in current nightly

Not really a downgrade, at the current stage 5.99 is a sandbox.
Anybody ho needs to ask the differences should be using 5.1.x