Outline around Pad

Hi everyone,
Newbie to KiCAD and schematic design, watched many videos, tutorials, etc.
I created a small test circuit with just traces to play around with Pads and edge cuts.
When I create Pads, they look fine in the footprint editor.
But when I drag them to the PCB, it adds a small line around it, which seems to mess up traces, teardrops and other things. What setting is this, am I doing something wrong here?
TIA

my understanding is it’s showing the “clearance” of the pad, which would be more apparent if you had a filled plane on your top layer.

Same here. Those lines are very likely for the clearance.
You can change the view of the pad clearance with the checkbox:
Pcbnew / Preferences / Preferences / Pcbnew / Display Options / Clearance Outlines / [x] Show pad clearance

Thanks!
Turned it off and it removed from the pads, but still seems to impact Teardrops.
Clearance Off

Hiding the clearance indicator doesn’t remove the clearance itself.

Judging by your footprint having REF** reference it didn’t come from schematic and probably doesn’t have a net. That would be why teardrop doesn’t work, they are essentially zones and zones don’t connect if they don’t have a matching net.

2 Likes

and i would imagine the trace that runs through the teardrop also has a default clearance established

To me it looks like you’re approacing it from the wrong side.
The clearances are real no matter whether you show the ring or not, as others have already posted. The clearances are also mandatory and very usefull. Without them KiCad would be worthless.

Teardrops are currently not integrated into KiCad, so you’re probably creating them with some script. I have never used these scripts and do not know what they exactly do. I assume they create a zone on the boundary between the pad and a track segment. The solution should be to make the teardrop itself part of the same net as the pads, so the clearance is not calculatated around the pad, but around the combination of the track + pad + teardrop.

1 Like

Right, there is no schematic.
I’m creating as flex circuit that is only pads and traces, no components.
So I skipped the schematic part, and went straight to pcb. Is that not how to accomplish what I’m trying to do?

You need nets to make zone based tear drops work.
Your options are:

  1. Create a schematic, it will take 5 minutes if it’s just a bunch of connectors wired together.
  2. Use WireIt plugin to create a net and manually assign that net to tracks and pads that need to have a teardrop
  3. Manually draw the teardrop using copper polygons (not zones).
2 Likes

Oh no. Not again.

Making a PCB without a schematic is simply a bad Idea.
Always especially in KiCad.

So draw a schematic with a few connectors, then draw connections between the connectors and assign footprints to the connectors, then put the whole thing into PCBnew with Eeschema / Tools / Update PCB from Schematic [F8]

I’ve seen to many people asking for some kind of solution for a problem they created by wanting to skip the schematic step, and even when told to make a schematic they stubbornly keep insisting on not making a schematic. I hope you are not one of them.

A schematic for such a cable is trivially simple, but it gives KiCad the basis to work with. KiCad is build around the whole concept of a netlist.

There are other ways to create a netlist, such as the WireIt plugin or SKiDL, but creating a schematic is the simplest way to create the netlist.

From my point of view you have the choice of either working with KiCad or against it.

5 Likes

FYI the unstable development version 5.99 has better support for schematicless designs. It’s possible to handle nets from inside the board file. But I think you would be better with schematic anyway in this case if you want to learn KiCad and PCB design. Schematicless is OK for very small designs if you know what you’re doing, but if you want to learn, it’s better to start with schematic.

2 Likes

Thanks for the advice, I’m a software guy so I get it. If that is how KiCAD is designed, then I’ll do it.
What I’m designing is a Flex circuit that has a very specific custom shape.
I’m replicated a foil circuit (just traces) from an old car, so there’s very specific size and placement requirements.
It has a custom 12 pin edge connector with traces to Pads on different places on the circuit that might connect to a through hole pad or custom pad.

What components would I add in the schematic for this setup?

For the schematic, it doesn’t matter greatly what symbol you use for the connectors. You could use Connector-Generic/Conn_01x12 and separate 01x01 for the individual pads or a bigger connector if there are groups of pads. All that matters is you have an internal net list that KiCad can work with.

3 Likes

Ah…I think the dim light bulb in my head just turned on… :crazy_face:
I think I get it now, why that is needed and how to do it.
gonna play with it later today.
Thanks!

1 Like

This seems to be a repeat of another post but, still you’ve not posted your complete process steps of doing it. Thus, difficult (for me) to identify the cause of problem.

I seldom make schematics in Kicad as I prefer my hand-drawn schematics so, to me, it has nothing to do with schematics, nets and symbols.

Just making a Footprint consisting of a Polygon-Shape and a Pad. Selecting both and Making A Pad from Shape.
I’ve fiddled with Paste, DWG, Mask, offsets… all of the tweaks when making a footprint and cannot get it to Fail or Repeat anything such as what you show. Perhaps it’s me and overlooking something.

I even deleted the Schematic file from the project - no problems… I’ve done this in versions 5.1.5, .7, .8 and .9 and no problems (using a Mac/OSX).

I suspect it’s how you’re doing it - try doing withOUT using a plugin…

Screen Shot 2021-01-05 at 9.37.32 AM

1 Like

How I’m doing it is very basic I think, as I’m super new to KiCAD.
I’m running V 5.1.6, just downloaded and installed a couple of weeks ago.
I’ve tried it on my Mac and PC.
1st, I go into Footprints and made a few Pads, then I place them on the PCB and connect them with some traces. That simple.
I installed the Teardrops plugin as suggested, and use that after everything is drawn.

I have three types of PADS. Two are standard and one is custom. the clearance shows up on all of them.

  1. Circular Through-Hold Pad
  2. SMD Rounded Rectangle Pad where I extend the X and Y
  3. Custom Pad which is a SMD Rounded Rectangle where I add on using the polygon tool, then select all parts to create a custom pad.

Thanks for posting your steps…

I somewhat mimicked your 3 pads (enough to demo it including extended X,Y, Pad/Die Length…)

Three Video’s…

Still, no problems…

I suggest avoiding plugins and deep-sea diving until you’re able to swim in the waters of simplicity…

1a.mov

2a.mov

3a.mov

I just found this setting…which maybe the issue.
Clearance was set at 0.2mm
When I change it to 0, it seems to go away.
And also found it in the properties of the teardrop at 0.2. If I change it to zero, it goes away. So, must be clearance settings as previously mentioned.

Must have been there by default. Do you have a clearance set in yours?

yes. Also have fooled with clearances in several panels but, though they may set the offsets of the lines around the pads, they never do what your’s does…

Again, do it without using a Plugin…

RE: your updated image… You do NOT have a Closed Shape. I cannot help further if not doing as I suggest but, only repeating what you’ve done… You need the foundational understanding first, then, figure out how to do stunt-deep-water dives…

1 Like

I’m trying…I appreciate your help.!
It seems that the clearance setting fixed the other SMD pads, but as you say the teardrop plug-in still is an issue.
I was just following the suggestion further back that I use teardrops.