NPTH to copper clearance on inner layers

I want a copper clearance to NPTH on inner layers. I cannot get that working, as only F.Cu and B.Cu are possible as copper layers.
Of course I could use a THT but I think NPTHs should keep the board-edge clearance as well although they are inmidst the board.

I think 7.0 enforces board-edge clearance on NPTH holes automatically.

But you should also be able to use a mechanical_hole_clearance rule.

If this is for 6.0, you might have to use a PTH.

@JeffYoung I’m on 6.99.


#make sure of NPTH clearance, all layers
(rule NPTH_Clearance
(constraint mechanical_hole_clearance (min 0.3mm))
(condition "A.Pad_Type=='NPTH, mechanical'"))

doesn’t work, however.


I expect to see a black ring around the hole. Orange is an inner layer btw.

DRC rightfully warns about violating the condition elsewhere, however.

There were a couple of bugs in the NPTH drawing code: we’d only draw the clearance ring when selected, and we’d draw it in the wrong colour.

However, I was wrong about mechanical_hole_clearance. You should just use hole_clearance.

Ok. Back to my original concern. Why can NPTH pad clearance only be set for the outer layers (F.Cu, B.Cu) and not for the inner layers? Or, phrased differently: why is there no “all copper layers” choice similar to PTHs. What’s the reasoning there?
Anyways, I’m fine with the PTH workaround, although that buys me “Padstack is not valid” errors due to drill=size, which I can disable.

@JeffYoung Btw, as for the custom designed rule: hole_clearance works for the NPTH, but also only for the outer layers. And it’s not a visual thing, it isn’t there in the Gerbers as well.

Well that’s not good…

Worth filing a bug?[20charsforrobot]

Nah, I’m already on it and it doesn’t need cherry-picking back to 6.0.5 (I broke it in 6.99).

Ok. I’ll wait for the commit, do a private build and confirm.

Fixes are in. (3 different commits.)


Works. No custom rule needed, just setting a pad clearance for the NPTH required.


What a pleasure to read a thread like this!!!


Great team work here.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.