Not possible anymore to move reference? [SOLVED]

I moved over to KiCAD 5.1.2 and I experienced it’s not possible to move the component reference to a better suited place.

This was possible with the good’ol 2013 version.

Is this regression or intentional?

I saw this: Unable to move footprint reference designator but that didn’t help me a lot…

I can move references like normal. Just hover over the text and press m. Worst case you get a disambiguation dialog asking you what to move. Another option is to left click to select the text and then press m. Or right click -> move.

If none of the above works then check which toolset is selected in the preferences menu. (select one of the others)

An instance where this is a bit annoying is like below… I have a normal sizes reference and a very small FAB layer reference, if I zoom in it still requires me to clarify… I think maybe it is using a bounding box and zindex now and previously it required you to click on the text itself (some of us got used to this behavior and find the clarification dialog annoying in these situations).

First off, in Pcbnew I only see the component reference if I select the component itself with the left-mouse click. IIRC, in the past the references were always visible.
Next, after selecting the component and moving the mouse over the reference, pressing m selects the whole component. I don’t see a popup telling me what I want to select.

I’ve tried the 3 different toolsets you pointed at but the result is the same: I can’t move the component reference to a better suited place…



Ok… That tells the whole story… I had References ticked but not Footprint Text Front. With References ticked only I didn’t see the component references. Only when I also ticked Footprint Text Front I saw the references and I could move the references using ‘m’…

Issue solved.

Thanks, eelik!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.