No circuit loaded

I have put together a simple boost DC-DC converter circuit which ERC checks clean, but when I start the simulator I get “Error: there is no circuit loaded.”
If I select “Simulation/Show SPICE Netlist…” it pops up the spice netlist which looks correct, however, any attempt to set simulation parameters or run the sim returns the same error.
Yes, I have loaded the KiCAD master spice library and pointed to the models for devices used.

Application: KiCad Schematic Editor

Version: 6.0.1-79c1e3a40b~116~ubuntu20.04.1, release build

wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-94-generic x86_64, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: Jan 15 2022 20:26:22
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.81.0
ngspice: 31
Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:

This error message typically points to an error in the ngspice netlist or with the associated models.

Please post the complete error message here, and the spice netlist, if possible.

Did you set the compatibility flag (e.g. to PSPICE and LTSPICE)?

1 Like

I have same error.


Note: No compatibility mode selected!
warning, can’t find model ‘vm’ from line
led1 gndref net-led1-pad2 vm
warning, can’t find model ‘v5.5mla0603h’ from line
rv1 gndref net-r1-pad2 v5.5mla0603h
warning, can’t find model ‘/vcout’ from line
u1 /vcout gndref net-r1-pad2 /vcout 48_vdc lt6015xs5
ERROR: mal formed B line: b1 48_vdc gndref dc(48)
Error: ngspice.dll cannot recover and awaits to be detached
Note: can’t find init file.

** ngspice-37 shared library
** Creation Date: Jun 24 2022 06:28:52

Error: there aren’t any circuits loaded.