No 3D models at all on Mac, only green flat pads

Hello. I know there are many posts regarding models not showing up, but I can’t seem to find a definitive answer. Almost all solutions I’ve seen involve windows or Linux, drivers, etc. Or they are caused when the user updates from an older version of KiCad.

  • I’ve gone through a ton of random parts in the library to see if any models show up, all show board footprints only.
  • Tried importing 3rd party step files and footprints. followed all instructions to the letter.
  • When I get the step file matched to the part, same thing, in the footprint/3D model dialog, it looks like the step file has been accepted, no warnings or anything, but the actual model doesn’t change at all.
  • I made sure all paths are correct.

So, I’m wondering if this is a problem that is being addressed and I need to sit tight and wait for an update, or if there is a solution to it and I’m missing it somehow.

Thanks in advance for your help.

Here is my info:

Brand new install of ver. 6.0.5-0 (never used KiCad before so install is totally clean)


Monterey ver. 12.2.1

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro16,1
Processor Name: 8-Core Intel Core i9
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 8
L2 Cache (per Core): 256 KB
L3 Cache: 16 MB
Hyper-Threading Technology: Enabled
Memory: 64 GB
System Firmware Version: 1715. (iBridge: 19.16.10744.0.0,0)
OS Loader Version: 540.80.2~11
Serial Number (system): C02ZR6NJMD6T
Hardware UUID: 22A81079-59D8-5124-A5FC-4EFA3E8F2D2F
Provisioning UDID: 22A81079-59D8-5124-A5FC-4EFA3E8F2D2F
Activation Lock Status: Disabled

I don’t know much about that computer brand, but I do know that the 2D footprint libraries are not always installed together with KiCad.

Can you single out a footprint, then use a file browser and verify the 3D file is in the location it should be? (Seeing a link for a 3D model attached to a footprint is no guarantee the 3D file itself exists).

Maybe we could work from your system? meaning, what is a component that shows the model just fine on yours, and I’ll check that exact one to see what I show?
Since I can’t seem to get any of them working, maybe this will help isolate it

I posted a screenshot of a 3D model that works for me here: 3D models missing KiCad 6 - #6 by gkeeth

Both the wrl and step models work for me

Here’s one that works for me. It’s the first footprint in the Capacitor_THT library. Full footprint name is in the screenshot.

Can you post a screenshot of what that looks like for you and make sure we’re talking about the same thing?

I recently upgraded to Monterey and Kicad 6.0.5. Many problems and still working though them. But, here’s something I just discovered:

Two PCB’s with the same Footprint and model (doesn’t matter if .Step or .Wrl). For one PCB, the model shows, for the other, it’s not showing.

Note: Both PCB’s belong to the same project folder and I have many projects with multiple PCB - never been a problem, so that’s not the problem.

Taking notice of the difference in the Paths panel, the Good one lists nicely, the Bad one lists with Greyed-out fields.

Field contents are the same (unless I’m crazy…)

I haven’t yet tried to re-establish the paths for the bad one but, will try that…

You might look into a similar scenario on your Mac…

EDIT: The last screenshot shows info from the Help button. I tells what ‘Grey’ means. But, Why in One Grey and the Other Not Grey - the entries are identical!!!

here’s what I get with the same part

I get the green-board only result there, and there is nothing grayed out. I even tried creating a importing an external footprint, creating my own off of that, then linking it to the external .step file. nada

this is the video I followed for instructions. KiCad 5, but from what I researched, it still applies to 6.

I suspect to ‘some degree’ our issues are related but, difficult to say what the problem is…

Generally, I think my problem arose from Updgrading to Monterey - it put some of my files (App’s/etc) in a Hidden USR directory and some in the proper place. Some were made into Alias’s and mixed them… (when I say ‘Hidden’, I don’t mean in the Contents dir, I mean in HD>vol…etc

In one PCB with bad result 3D, I was able to ‘Update’ it and get the 3D to show. In others, Update did Not work but, Replace it did… And, putting a New (well used, good) footprint on a PCB did not show until I Replaced the 3D… A mixed bag of problems!

Confirming that, in another, New PCB/Project, I added an LED, it didn’t show (even though there was no indication of problem. I replaced the 3D with the same 3D and it showed…

Most likely a combination of Kicad and Monterey.

But, you know, Kicad is only at 6.0.5 so, perhaps we’ll see improvements by year’s end…

I just re-installed Kicad 6.0.5 without any improvement.
However, I had No Problem placing the Capacitor you’re not able to see 3D of…

I’m not fully up to speed about how things are packaged for MacOS, but I’ll try to help anyway.

Can you screenshot the Preferences → Configure Paths… dialog?

I read over your replies (thank you) but I’m still a little confused.
I can’t quite wrap my head around the scenario where you had it showing on one project, but not on the other.
Keep in mind, I’ve used Macs for many years, but have never delved into changing paths, or doing things on a code/command line level.
Perhaps you can expand on this a bit?
Also, you said the reinstall did not improve things, but it seems like now you are able to see the part? So doesn’t that mean it DID fix the issue?

Two issues: 1) The Mac (OSX Monterey) and 2) Kicad

Naturally, the Mac affects Kicad and I had too many issues with Monterey. But, I re-installed Monterey and Kicad, dug into the hidden files and did a lot of cleaning. Resulting in ability to now set permissions without jumping through hoops and responding to a zillion prompt-panels.

Back to Kicad:
That said the only remaining issue I have is seeing 3D models on old projects. Some appear, some don’t and all are on my system and linked correctly to older Kicad files. Something does Not want to get updated when I reset them.
But, rather than fussing with them, it’s quicker/easier for me to simply Change the footprint and reselect the existing one - two clicks (per item on PCB) and I’m done.

The Image with the Side-By-Side two panel-view shows the same footprint, same links/paths yet, one is Not showing as it should (not like the one next to it). If you see a Typo/other that I’m not seeing, I’ll buy you a cup of Coffee!

Adding/selecting my Models and Kicad Stock Models works fine for new projects (and adding to Old projects) - it’s only about 1/2 of existing old projects with trouble. I’m not worried about it.

Now, to your needs:
I’m sure I was not clear, leading to your confusion.

So, if you’re still having trouble, consider theses steps:

In a different user’s post, review my comments - I walked through the steps of setting up… This Post
There are some gif videos… they have a Play/Pause btn at lower right corner.

Thus, when dust is settled:

  1. Ensure your Paths are correctly set (use UTF-8 font, no spaces or symbols).
  2. Always Quit Kicad after setting Paths
  3. Create a New Project and add a few Footprints to it (no need for Schematic). You can make some connections on Top/Btm layer and draw shape on Edge_Cut layer.

Result: You should see good result when looking at it in 3Dview.

If problem, then we can go from there

thank you for the detailed reply.
I actually was able to get it working with a workaround (maybe this will be helpful for someone else).
For some reason, If I go in to a part that has already been placed on the PCB in PCBnew, click on the properties of that part, go to “edit library footprint”, go to the 3D tab, link it to my external 3D model (.step file), then hit the save button on the upper left, it will show and place the model on my PCB.
After doing all that, if you have multiple of that part already plaed on the board (like I did) simply click the other parts, and “update all from library”.
If you like the one’s I have, I got most of them from this creator on grabCAD (free).

Also, the other small parts have now shown up on the model as well. I didn’t do anything to make that happen… they just started up after I got the first 3D model working. No idea why?

follow up… then KiCad crashed, and all the updated footprints with 3D models were lost. Incredibly frustrating.

That’s how it’s supposed to work, and did, until I updated to 6.0.xx and updated to Monterey.
But, as I said,

and, fussing “…with them…” includes Kicad’s Tools (update from schematic, update footprints from library)…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.