The difficulty of adding components to Kicad

What kind of footprint file do you have? Does it end in .kicad_mod? If so we can walk you through the steps from there.

  1. Think of a place where you want to store your library. (Only in your head, not in your PC).
  2. Open a KiCad project (Any KiCad project).
  3. KiCad Project manager / File / New Project
  4. In the file browser window, go to the location you thought of in step 1, and create the KiCad project.

KiCad then does this for you:

  1. It creates the project directory.
  2. It creates the project files, with the same name as the directory.
  3. It switches to that project and makes it the active project.

Make notes of what you do. Copy the lines of text from this forum that help you to understand it into a text file, and update that text file in each step.

Hi P,
That’s fine.
I did try using the (file manager program), and know how to do that.
Thanks for your help.

Hi G,
The name of the file I made is (ak8963c.lib) I can now see that if I open it in Wordpad, it is a SCH file, so that must be why I can make a SCHEMATIC.

Yesterday I made a PCB FOOTPRINT, but wasn’t allowed to save it, by Kicad. Either that or I lost it :slight_smile:
Thanks, C.

Hi P2,
I can do that ok, and have tried a few times. Once I get mixed up I clear Kicad, including APP DATA and re-install it, to try again fresh. So far no success.
This is why I want to try ‘small steps’

Forgive roughness and lack of steady-hand/etc… 10 Cups of BlackCoffee!

• Assume you know nothing and are starting from Scratch as a NOOB

• You want a Symbol with a Footprint linked to it (Though, that’s not necessary but, we’ll do it)

• You want a Footprint with Linked 3D representation of 3Dmodel

Thus, these steps:

  1. Create a Folder for your Symbols

  2. Create a Folder for your Footprints

  3. Create a Folder for your 3D (Step and/or WRL files)

  4. Setup the Paths for the Symbols, Footprints and 3D files

  5. Create a Footprint (Footprint Editor)

  6. Create a Symbol (Symbol Editor)

  7. Link the Footprint to the Symbol (in Symbol Editor)

  8. Use them in Schematic and PCB

The videos (gif) show basically the full process

NOTE: I did NOT fuss with accurate dimensions/details - not important for conveying the process steps…
Yes, I know you’re going to use a Chip but, that’s just a small detail and, yes, you can have pads/etc…

The Footprint

The Symbol

Using It

Screenshots of Paths

You might want to look at a chat type platform to ask for help in ‘small steps.’ Discord & IRC | KiCad EDA

Hi BC,
The almost perfect way to answer my question!

I had to learn how to get my GIF viewer to stop/reverse/fast forward etc, so I didn’t have to wait for the loop. (IRFANVIEW)

I’m clearing out all previous instances of the compass, so I don’t bump into them later.

I’ll be back!, once I’ve succeded.

Thanks very much. What kind of coffee do you like?

What kind of coffee do I like? Black

I’ve been roasting coffee beans every week for the past 20+yrs - have tried many kinds but my ‘goto’ kinds are Nicaragua and Columbian (sometimes Costa Rica).

Most folks don’t know/realize what real coffee tastes like because most roasters burn the beans (difficult to control large batch roasting).

Good luck with the files…

Hi BC,
I’m happy with instant! I suppose that’s a swear word in your world?

I’ve gone round your instruction loop a couple of times, each time starting from fresh.

I’m able to set-up CAMERART libaries, and made a FOOTPRINT, but I’m not able to make new SYMBOL.

In the SYMBOL editor, I’m unable to start? I use new SYMBOL.

The FOOTPRINT has a wizard, which is great, but I haven’t found one in SYMBOLS.

What to do?

EDIT: When I try to configure the path to theCAMERART SYMBOL library, Kicad makes a NEW library. If I then try to make a SYMBOL, it allows me.

Best to always Quit Kicad after making edits to the paths, names… Then, restart Kicad.

No spaces or Gliph, rich-text font (use UTF-8).

Ensure your files/folders have Read&Write to you…

And, First ‘Select’ a folder in the panel (where you want the Symbol to go), then click new Symbol…

Hi @camerart

The problem is your symbol library has, for some reason, not been added correctly.
So, highlight your “z_camerart_symbols” library in the last screen grab and use the rubbish bin symbol just beneath the library to delete the library.
This won’t destroy your library, it will just delete it from the list.

Next, close that page.

Next, open Schematic Editor.

Next, open symbol editor.

Next, click File/ Add library / Global / OK then up comes a page that is titled “Select Library”

Next, use the column on the left to find your library… in your case it will be D: \Main\technical etc.

Next, when you finally get to the library, double left click it.

It should now show up in the list of libraries in your symbol editor in alphabetical order… so because it starts with a z it will be at the bottom.

Next, highlight (select) your personal library in the libraries list in your first screen grab as the sign in yellow “No symbol library selected” says, then go ahead and create your symbol by clicking on the IC symbol.

Hope this helps.

Hi BC,
I’ve tried everything. Re-starting, even un/re-installing Kicad.

Yesterday, I spent the afternoon, being helped by an ex BT techincal engineer, and it defeated us.

This seems to happen everytime, and as I said at the beginning, it’s not user friendly.

I’m sure there are some of you, that sail through, with no problems, and can’t understand, but there it is.

Well, we (me) might be chasing our tail…

I recently posted this, perhaps somewhat related (at least with respect to Kicad creating duplicate links…). Main point being, Open-source programming will never be Prime-Time viewing (IMHO)

Hi Black Coffee,
I noticed on Camerarts’ second screen grab that his file does not end with “kicad_sym”

Could this be his problem? That was the reason for my post.
I’m not familiar with Apple.

Hi J,
I got to here: Next, when you finally get to the library, double left click it. then got this ‘screen shot’ I didn’t add the SYM text! It came from nowhere.

I think, if everyone’s ok with it, it’s best to go back to square 1.
I’ll clear out APP DATA and re-install Kicad 6 fresh.
I’ll start a PROJECT file, called AK8963C (16 matrix BGA 1.6x1.6)

I’ll then have empty SCH and PCB.

Next please advise, one step at a time.

Scroll down your library list on the left and see if you have a library “New Library” at N

SYM’s get created (usually in the project’s folder and No Need for user to do any linking to them…)

Hi again,
I was trying to make Cameras’ personal library “D:\main\etc.” accessible to kicad. He could then select that as the library in which to place his IC.

Repair by remote is not easy :slightly_smiling_face: