The difficulty of adding components to Kicad

What kind of coffee do I like? Black

I’ve been roasting coffee beans every week for the past 20+yrs - have tried many kinds but my ‘goto’ kinds are Nicaragua and Columbian (sometimes Costa Rica).

Most folks don’t know/realize what real coffee tastes like because most roasters burn the beans (difficult to control large batch roasting).

Good luck with the files…

Hi BC,
I’m happy with instant! I suppose that’s a swear word in your world?

I’ve gone round your instruction loop a couple of times, each time starting from fresh.

I’m able to set-up CAMERART libaries, and made a FOOTPRINT, but I’m not able to make new SYMBOL.

In the SYMBOL editor, I’m unable to start? I use new SYMBOL.

The FOOTPRINT has a wizard, which is great, but I haven’t found one in SYMBOLS.

What to do?

EDIT: When I try to configure the path to theCAMERART SYMBOL library, Kicad makes a NEW library. If I then try to make a SYMBOL, it allows me.

Best to always Quit Kicad after making edits to the paths, names… Then, restart Kicad.

No spaces or Gliph, rich-text font (use UTF-8).

Ensure your files/folders have Read&Write to you…

And, First ‘Select’ a folder in the panel (where you want the Symbol to go), then click new Symbol…

Hi @camerart

The problem is your symbol library has, for some reason, not been added correctly.
So, highlight your “z_camerart_symbols” library in the last screen grab and use the rubbish bin symbol just beneath the library to delete the library.
This won’t destroy your library, it will just delete it from the list.

Next, close that page.

Next, open Schematic Editor.

Next, open symbol editor.

Next, click File/ Add library / Global / OK then up comes a page that is titled “Select Library”

Next, use the column on the left to find your library… in your case it will be D: \Main\technical etc.

Next, when you finally get to the library, double left click it.

It should now show up in the list of libraries in your symbol editor in alphabetical order… so because it starts with a z it will be at the bottom.

Next, highlight (select) your personal library in the libraries list in your first screen grab as the sign in yellow “No symbol library selected” says, then go ahead and create your symbol by clicking on the IC symbol.

Hope this helps.

Hi BC,
I’ve tried everything. Re-starting, even un/re-installing Kicad.

Yesterday, I spent the afternoon, being helped by an ex BT techincal engineer, and it defeated us.

This seems to happen everytime, and as I said at the beginning, it’s not user friendly.

I’m sure there are some of you, that sail through, with no problems, and can’t understand, but there it is.

Well, we (me) might be chasing our tail…

I recently posted this, perhaps somewhat related (at least with respect to Kicad creating duplicate links…). Main point being, Open-source programming will never be Prime-Time viewing (IMHO)

Hi Black Coffee,
I noticed on Camerarts’ second screen grab that his file does not end with “kicad_sym”

Could this be his problem? That was the reason for my post.
I’m not familiar with Apple.

Hi J,
I got to here: Next, when you finally get to the library, double left click it. then got this ‘screen shot’ I didn’t add the SYM text! It came from nowhere.

I think, if everyone’s ok with it, it’s best to go back to square 1.
I’ll clear out APP DATA and re-install Kicad 6 fresh.
I’ll start a PROJECT file, called AK8963C (16 matrix BGA 1.6x1.6)

I’ll then have empty SCH and PCB.

Next please advise, one step at a time.

Scroll down your library list on the left and see if you have a library “New Library” at N

SYM’s get created (usually in the project’s folder and No Need for user to do any linking to them…)

Hi again,
I was trying to make Cameras’ personal library “D:\main\etc.” accessible to kicad. He could then select that as the library in which to place his IC.

Repair by remote is not easy :slightly_smiling_face:

Hi J,
I’ve started fresh, so nothing is anywhere so far. I have a PRO, SCH and PCB, which are empty

Hi J,
Yes, that’s what I want D:\main\etc
No it’s very difficult. :frowning:

Create three folders with your operating system, NOT kicad.
Name them whatever you wish.
One for Kicad symbols, one for Kicad footprints, one for Kicad 3D

Hi J,
As I don’t need 3d, I’ve now got two folders, SYM and FOOT

Next open Kicad
Go to Schematic editor / Symbol editor / File / Global…OK /

You will open a page that is titled “New Library”
UP the top it says "New_Library.kicad.sym

Replace the “New_Library” part with a name for the library.
I’d suggest the name "1_ICs_BGA.
Prefixing with the number 1 will place your library at the top of the list.

So the name will look like: 1_ICs_BGA.kicad.sch

Next, use the list on the left to navigate to the new symbol folder you created with your OS.
You will need to go to D:\SYM

Click save (at the bottom)

Hi J,
Not 100% but I think it’s as you suggest, but Z_ AK8963C at the bottom

Sorry, I missed a step. Give me a couple of minutes to edit my above post.

z is OK. Just as you wish.