3D models missing KiCad 6

If your drivers are up-to-date, then I don’t know what else to suggest. Issues like this are typically from hardware/drivers that have poor OpenGL support, which unfortunately is not uncommon. KiCad requires support for OpenGL 2.1 (~2006).

Indeed, I missed that detail.
For me the PIC progrmmer demo also looks complete, with all3D models present just like in the screenshot gkeeth posted.

In the first screensthot from Drexter it only shows the LED’s and the diodes, and those are default footprints:


However, if you look at for example the ZIF socket, then you see it’s in a project specific location:


@Drexter Have a look at the path to the 3D model in the footprint properties, and then check if the referred 3D files do exist on your PC.

(Removed a naive assumption)

I already checked, everything is where it is supposed to be.

But I did do some snooping around the forum searching with keywords “graphics” and “3D viewer” and I stumbled upon this [SOLVED] 3D objects not visible in realtime renderer, only in raytrace render

And to my suprise, using raytracing mode in 3D viewer, everything is now visible. I can’t speak for the opacity changing method, since I do not even know how to do that yet. But with raytracing it definitely works, it just takes ages to regenerate the model after even the slightest rotation/move.

That again points to your graphics drivers/hardware as the issue, unfortunately.

Yeah it does seem like it, which is quite suprising as it is a GPU that is not that old and is supposed to be a professional CAD GPU.

That is a shame thought, seems like there is no fix for this.

What happens if you try the legacy graphics option, which avoids the OpenGL

How can I turn on that option ? Haven’t seen such an option in preferences.

PCB Editor / Preferences / Preferences / PCB Editor / Display Options / Rendering Engine / Fallback Graphics

This test will confirm if this is a driver bug

Hi @Drexter this is a known 3D bug on some specific AMD GPUs.

It was fixed last month and should only be available on the next stable releases of KiCad 6.0.5

If you don’t want to wait, there are the nighbuilds of kicad that you may want have a try.

1 Like

I will give it a go once I get to the pc. Thanks.


That’s great news. So I will just wait. Thanks a lot.

it should available also on stable-testing (aligned to stable but with latest improvements)


The legacy graphics option just changes the 2D schematic/board editor canvas. The 3D viewer will still use openGL when raytracing is disabled.

6.0.5 was released, could you give it a try?

Even if it is not on release notes (missing?), can you test if it was fixed?


Hey @kammutierspule

I can (happily) confirm it works like a charm now. PCB shows in the 3D viewer without any problem.

Thank you


Identical issue, but I’m on a mac, (non-M1). No components show up, even imported some fresh one’s followed the instructions to the letter.
Any advice is appreciated.
edit: File type I tried to import is a .step file

Not an identical issue if you can see the board. OP in this thread had problems displaying the board itself, never mind the models for the components placed on the board :slight_smile: See their screenshot 3D models missing KiCad 6 - #5 by Drexter

Your issue sounds more like a paths issue, possibly. Let’s help you in your original thread and keep this one focused on the driver issue here.

maybe this will help someone. Similar issue I sorta solved by accident. no idea if it will work for others… No 3D models at all on Mac, only green flat pads - #15 by Al_J

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.