3D models missing KiCad 6


I installed KiCad and ran into some trouble. The majority of 3D models are missing from the 3D viewer (see picture of one of the demo projects shown in 3D viewer). Also no models are shown when I try to look at parts in footprint library. I checked and the files are present on the drive, located in C:\KiCad\6.0\share\kicad\3dmodels

There was no previous installation of KiCad on this computer.

KiCad version
Application: KiCad (64-bit)

Version: (6.0.4), release build

wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19044), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Mar 18 2022 03:04:44
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.6.0
Curl: 7.78.0-DEV
ngspice: 36
Compiler: Visual C++ 1928 without C++ ABI

Build settings:

As said in my post, there was no previous installation of KiCad on this pc, never even used KiCad 5 before. I did a clean install of KiCad 6.

Many footprints in KiCad’s library do not have 3D models created for them. However, the library team’s policy is that all footprints should have a 3D model filename included, even if the model itself does not exist yet. That way, when someone creates & submits a model, the model will be found automatically without the footprint file needing to be updated. However this can be confusing when a footprint lists a model that does not appear or even exist.

Can you give an example of one of the footprints that does not show a model? You can either check whether a model for that footprint exists in your installation or I can check.

If that’s not the issue, then we’ll need to do some further debugging.

1 Like

For example AT89C2051-12P.

This is what I see when I add it and have a look in the 3D viewer.

Is that the pic programmer demo? For me that looks like this:

I think you have a broader problem which is that the board itself isn’t displaying properly. I don’t want to spend any time debugging the model files and paths when the 3D viewer is fundamentally not working for you.

What is your graphics card and can you update the drivers?

Except that the AT89C2051-12P is a schematic symbol, and schematic symbols do not have a footprint…

I did put an AT89C2051-12P on a schematic though, and by default it links to the footprint: Package_DIP:DIP-20_W7.62mm

And that footprint links to the 3D model:


… and that 3D model is present on my PC and it shows correctly in both the 3D preview and the 3D viewer itself:

@gkeeth The pic programmer demo is from way before Microchip bought Atmel and does not have that chip.

I have an AMD FirePro W5170M, with the latest drivers.

Yeah sorry I messed up with the example chip, I’m completely new to to KiCad.

The point is that yes my first post was the PIC programmer, and it seems it works for gkeeth, but not for me. Neither does the chip show up for me, but obviously you can see it in the 3D view.

That may be true, but the components on the PIC programmer demo match what is in the first screenshot, with some squinting to ignore everything that’s missing. Still, I would like @Drexter to specify which demo.

I just updated Why a footprint points to a 3D model but the model file doesn't exist? with a screenshot from v6. You can see there if the footprint actually has a 3D model file available. But this time the problem is probably in the graphics, we have seen these before, and it has been a graphics card/driver issue.

If your drivers are up-to-date, then I don’t know what else to suggest. Issues like this are typically from hardware/drivers that have poor OpenGL support, which unfortunately is not uncommon. KiCad requires support for OpenGL 2.1 (~2006).

Indeed, I missed that detail.
For me the PIC progrmmer demo also looks complete, with all3D models present just like in the screenshot gkeeth posted.

In the first screensthot from Drexter it only shows the LED’s and the diodes, and those are default footprints:


However, if you look at for example the ZIF socket, then you see it’s in a project specific location:


@Drexter Have a look at the path to the 3D model in the footprint properties, and then check if the referred 3D files do exist on your PC.

(Removed a naive assumption)

I already checked, everything is where it is supposed to be.

But I did do some snooping around the forum searching with keywords “graphics” and “3D viewer” and I stumbled upon this [SOLVED] 3D objects not visible in realtime renderer, only in raytrace render

And to my suprise, using raytracing mode in 3D viewer, everything is now visible. I can’t speak for the opacity changing method, since I do not even know how to do that yet. But with raytracing it definitely works, it just takes ages to regenerate the model after even the slightest rotation/move.

That again points to your graphics drivers/hardware as the issue, unfortunately.

Yeah it does seem like it, which is quite suprising as it is a GPU that is not that old and is supposed to be a professional CAD GPU.

That is a shame thought, seems like there is no fix for this.

What happens if you try the legacy graphics option, which avoids the OpenGL

How can I turn on that option ? Haven’t seen such an option in preferences.

PCB Editor / Preferences / Preferences / PCB Editor / Display Options / Rendering Engine / Fallback Graphics

This test will confirm if this is a driver bug