Nightly / version 5 - 3D File Resolver No such path


#1

I recently built a new Windows 10 64-bit PC. On the previous PC, I originally installed the stable release of KiCad, then upgraded to nightly builds. The 3D modeling “just worked”.

On the new PC, I did not install the stable release, but instead went straight to the nightly build. I followed these instructions to pull the 3d models from git.

However, when I load a 3D model, I get a dialog that says “[3D File Resolver] No such path; ensure the environment var is defined” and it gives the path to a wrl file (see image below). The path that is shown does exist. I’ve checked and double-checked, the file does in fact exist in path shown. Furthermore, if I open a command prompt and run set, I have the following environment variables defined:

KICAD_PTEMPLATES=C:\Program Files\KiCad\share\kicad\template
KICAD_SYMBOL_DIR=C:\Program Files\KiCad\share\kicad\library
KISYS3DMOD=C:\Program Files\KiCad\share\kicad\modules\packages3d
KISYSMOD=C:\Program Files\KiCad\share\kicad\modules

And also in my DOS window:

C:\Users\matt>dir "c:\Program Files\KiCad\share\kicad\modules\packages3d\Capacitor_THT.3dshapes\CP_Radial_D10.0mm_P5.00mm.wrl"
 Volume in drive C has no label.
 Volume Serial Number is 649B-51E0

 Directory of c:\Program Files\KiCad\share\kicad\modules\packages3d\Capacitor_THT.3dshapes

03/17/2018  11:53 AM           102,100 CP_Radial_D10.0mm_P5.00mm.wrl
               1 File(s)        102,100 bytes
               0 Dir(s)  322,950,868,992 bytes free

I’m sure I’m missing something silly. This on the March 23 nightly (but it also happened with a previously nightly I was using).

Thanks for any help! (Excited to see if my new Ryzen CPU does faster raytraced renders!)


#2

From the example you gave…

Existing:
“c:\Program Files\KiCad\share\kicad\modules\packages3d\Capacitor_THT.3dshapes”

Looking for:
c:\Program Files\KiCad\share\kicad\modules\packages3d\Capacitors_THT.3dshapes…"

If I were to guess the folder values in the footprint files (which point to the 3d shapes) are off for some of them - or the other way around - the 3d shape folder names don’t match what the footprints expect.


#3

From the information found by @Joan_Sparky i can guess what the problem might be.

Option 1 you have downloaded the new 3d libs but did not download (or activate) the new footprint libs. (Your fp-lib-table might still point to old libs. If any of the paths in there starts with KIGITHUB you still use the on demand libs.) Use the library manager found in pcb_new->preferences menu (It might now have been moved to the setup menu.)

Option 2 you look at a project to which you made before you updated the libs. Kicad stores the footprints in the pcb file when you add the footprints to it (by importing the netlist or when using the update from schematic tool.)
But 3d models are not stored within the project in any way. So if you then update the 3d model libs there will be trouble.


#4

Funny things happen when the user creates files under c:\Program Files. Instead of being created there, they are created in the “virtual store”. To the user it looks like the file exists under Program Files, but the application can’t see it.

I don’t think the instructions in that other thread are good advice, tbh.


#5

One recent change in Nighties was to generate a warning when a 3d model was not found, rather than just silently failing to render it


#6

Ahhh, I knew I was missing something subtle!

I think that is it. I opened the schematic and all my symbols were question marks. I neglected to read Testing: Symbol Library Table Released.

Thanks to this thread, and that link, I now have more info on this stuff, I think I can now get my designs fully “compliant” with the version 5 / nightly system. Still need a little elbow grease before it’s all fixed, but I think I can get there.

Thanks all!


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.