Newcomer: how to stop Pcbnew from angling tracks?


#1

I’ve just started using Kicad - looks good - but can’t figure out how to stop Pcbnew from automatically angling tracks at 45 degrees. Even after clicking on a desired right-angle location, it redraws the track at 45 degree increments as I move the cursor, even shorting across the SOP14 pads I’m using.

I’ve looked through the docn and all the menus, but can’t see anything like I’m used to from other CAD programs. I’ve also hit the slash key (/) without any effect.

Any assistance much appreciated.


#2

1)First, select OpenGL:
a]Press “F11”.
b](or find and click it on the menu bar under “View”)

2)Select a copper layer:
a] Depress keyboard key, “PgUp”
b] (or find and click it on the far right menu bar)

  1. Select the task to perform:
    a] Depress the keyboard key, “x”.
    b] (or find and click the icon “Add tracks and vias” button on the inside right menu bar)

4)Open Routing Options:
a] Depress keyboard key “e”.
b] (or right click mouse button and select “Routing Options” from the menu)

  1. Enable Free angle mode:
    b] left click and CHECK the “Free angle mode (no shove/walkaround)” check-box.

NOTE: that if your traces are “OFF-grid” there will be a 45 degree segment section of the trace to get the trace “on-grid”.


#3

Are you asking for free angle or just 0 and 90 degrees?


#4

… with 90 degrees being strongly discuraged, to say the least.


#5

Well i always was told they are bad but nobody ever brought fourth any evidence for it.
The only thing i found when i researched it myself seems to contradict the tale that 90° corners are bad:
http://www.ultracad.com/articles/90deg.pdf

And the first answer to this question on stack exchange gives one exception. It states that only high voltage boards should not have sharp corners. There seems to be no measurable benifit from a standpoint of EMI when comparing 45° to 90° angles.


#6

OK, I expected this as soon as I hit ‘reply’ :slight_smile:
I agree. I was questioning myself, where all these "do"s and "don’t"s originate. Never know. Some of them may qualify as myths.


#7

90 degree corners do cause tracks to be longer than they need to be

Back in the days of tape layout and toner transfer they were prone to excess etching on the inside of the bend


#8

Thanks for all replies. i’m using Pcbnew 22 Jun 2014 BZR 4027 build as supplied with Debian 8.2.

First, select OpenGL: Press F11 (or find it on the menu bar under “View”).

F11 gives Full Screen mode. The entries in the View menu are:
Zoom In
Zoom Out
Fit on Screen
Redraw
3D Display
List Nets

Click and CHECK the “Free angle mode (no shove/walkaround)” check-box.

Can’t find it. In Preferences > General I’ve tried ticking and unticking both “Limit tracks to 45 degrees” and “Use double segmented tracks” without success.

Say I start a track on a pad in a SOP14 footprint. I then move horizontally a few grid points and click again; in other programs this inserts an “anchor point” from which a new track segment starts, so that when I move vertically, the new segment begins at that point. Instead, as I move vertically, the whole track either swings with the movement or jumps in 45 degree segments. I end up with the track shorting across the other pads in the footprint.

How do I stop this from happening?


#9

First things first: when routing, set the grid to the finest resolution (0.01 mm in metric). There is no reason to use a coarser routing grid.

Next, use the OpenGL routing mode. It’s better than the default canvas. In shove mode, it’ll move other traces so that it never has a clearance issue. It won’t move parts, but it will move vias.

Remember to click in the middle of a pad when starting a trace. With Preferences -> Magnetic Pads set to “when drawing tracks,” the cursor should “snap” to the middle of pads automatically when the draw-trace tool is active. (Set Magnetic Tracks to the same setting, so you can be sure that when you continue a previously-drawn track that doesn’t end on a pad, that it starts at the end of that track.)

And remember, as you draw your traces, clicking to set an “anchor” point is good, and you may have to use the [/] key to change the track “posture,” which is how it wants to route from each “anchor” point.


#10

Get a more recent release of KiCAD! There are MAJOR improvements and SIGNIFICANT changes since your version was distributed. The 4.0.5 and 4.0.6 releases include many of the improvements; the “Nightly Builds” have even more features. (I’ll even vouch for the quality and stability of nightly builds up through the first week of February or so; more recent nightly builds are significantly buggier and occasionally unusable.)

Dale


#11

I was wondering if the OP’s version might have something to do with the issue.


#12

The great majority of folks here on the Forum have moved on from that “Old Stable” version, so even getting reliable help for it is a problem.

Dale


#13

Thanks again for the suggestions. From what’s been said I think my version may be at least part of the problem - can’t see an OpenGL mode anywhere in the GUI.

I’ll call it quits until I’ve upgraded and checked the newer release.


#14

You can download installation packages for recent releases from the official KiCAD site at www.kicad-pcb.org . It may take a few minutes to download, and the installation takes a minute or two. On my Windows 7/64 machines the current package simply installs on top of the previous package. (Yeah, that can clobber your local symbols and footprints if you keep them inside KiCAD’s library files.)

In PCBNew, pressing “F11” shifts to the OpenGL display, and “F9” restores the classic display.

Dale


#15

I use Linux and have F11 bound to Full Screen in the window manager, so may need some adjustments.

Thanks for the tips.


#16

From pcbnew’s main menu, choose View => OpenGL Canvas.


#17

Ah, that’s a relief. Thanks.


#18

Nightlies are not for beginners.
BZR 4027 is only around for opening old projects. New users should use 4.0.6, which has a more or less complete OpenGL features and is the only version officially supported


#19

It all depends upon the nightly one gets I suspect.

I’ve been EXTREMELY happy with the nightly that I have; haven’t yet found a bug that crashes the program. And, has FIXED some bugs in the stable, with a couple of new cool features as well.

I also do NOT recommend a new nightly. However, as stated, a nightly that is NOT bleeding edge is probably going to be fine. The closer one wants to get to the bleeding edge will perhaps find themselves with a bloody nose.


#20

Not quite, the point is that some nightlies are pretty stable (around the date given) as not much changed in the code during that time - in contrast to last couple of weeks.
They ALL were bleeding edge upon creation :wink: