New BOM tool locks up V8

Hi all,

I tried the new BOM tool in Schematic, but locks up.

I get a blank dialogue box “Symbols Fields Table”, then it locks up.

I tried it in both V8.0.0 and V8.0.1 - same result.

sudo kill kicad unlocks it!

Kind regards

Maybe same issue as KiCad 8.0 - Hangs on Tools->Create Bill of Materials... (#17452) · Issues · KiCad / KiCad Source Code / kicad · GitLab ?

Thanks for your reply - Yep, that’s the one.

Kind regards

can you please post your system/kicad version info? (Help → About → Copy Version Info)

Application: KiCad x86_64 on x86_64

Version: 8.0.1, release build

wxWidgets 3.2.4
FreeType 2.13.2
HarfBuzz 8.3.0
FontConfig 2.15.0
libcurl/8.6.0 OpenSSL/3.1.4 zlib/1.3.1 brotli/1.1.0 zstd/1.5.5 libidn2/2.3.7 libpsl/0.21.2 libssh/0.10.6/openssl/zlib nghttp2/1.59.0 OpenLDAP/2.6.6

Platform: openSUSE Tumbleweed, 64 bit, Little endian, wxGTK, X11, KDE, wayland

Build Info:
Date: Mar 15 2024 11:10:26
wxWidgets: 3.2.4 (wchar_t,STL containers) GTK+ 3.24
Boost: 1.84.0
OCC: 7.7.2
Curl: 8.6.0
ngspice: 42
Compiler: GCC 13.2.1 with C++ ABI 1018

Build settings:

Could you provide an example project? I don’t think any of the developers have been able to reproduce this so we haven’t been able to fix it.

No probs.

But how do I attach it?

Kind regards

ZIP it up and upload it . . .

image (12.3 KB)

1 Like

Unfortunately, I still can’t reproduce this. Does the BOM tool lock up with a blank schematic / no-project?

Thanks for your reply.

It may be at my end - I’m using SUSE-Tumbleweed, and they are transitioning the GUI from Plasma X11 to Wayland, and the road has been a bit bumpy…

I’m not 100% sure about this time line - It wasn’t working with V8.0.0 and Plasma X11.

I’ll try it with a empty project shortly.

Kind regards

I tried it with a empty project - seems to work okay.

Added a single resistor - locks up.

Is it something silly like a python library function not being able to handle the different win/ linux end-of-line characters…

Kind regards

Could you do a:

strace -p $(pidof kicad)

to see where it’s waiting, or spinning its wheels?


I started the trace just after loading the schematic of my empty project with a single resistor.

Kind regards
kicadtrace.log (545.0 KB)

Also, if I delete the resistor from my empty project, save it, the BOM works again.

Kind regards

Hard to say, but it does seem to be waiting for a polled event. Maybe even from the windowing system. Can you try it under X11 instead of Wayland?

No, not at the moment anyway - the machine is a bit busy…

I’m not sure if I can select the GUI with Tumbleweed??? There are a few options in the bottom left corner when booting, I can’t remember what they are…

What I do know is - I found this issue shortly after the 7th of March using V8.0.0. I didn’t raise it here then because I knew V8.0.1 was on its way. The transition to Wayland began around 14-15th March. The last BOM I generated, using the legacy method, was on the 14th March - I know that this issue was there before I generated this BOM.

I’m very confident that the issue was there with X11, using V8.0.0…

Kind regards

After looking at some logs with a bit more detail, I can now confirm that the transition to Wayland, for me, began late on the 15th March. Therefore, this issue was present with X11…

Kind regards

You’re in a bit of a bind, as openSUSE is not one of the supported platforms so you’d have to wait for someone to confirm the bug on a supported platform. I can’t help as I’m still on 7.0.9 on 15.5 and in no hurry for the upgrade. I don’t have issues with my simple projects so the update can come when it comes.