New 6.0 install, Manage Footprint Libraries option missing

I just installed KiCAD 6 and started a new project. I’ve used Eagle for 20+ years and wanted to move to either EasyEDA or KiCAD, and settled on KiCAD (didn’t care for EasyEDA).

So all is well, until I wanted to add symbol and footprint for an ESP32 DEVKIT V1 module. No problem adding the library, but there’s no option in the Preferences menu for managing footprints.

I don’t have Preferences > Manage footprint libraries

After extensive searching, seems everywhere I read, that option should be there and expected by default, so I can’t find a solution to my dilemma where it’s simply AWOL. What am I missing?


Here’s what my Preferences menu looks like.

Any suggestions as to how I can fix this?

Your’re currently in the Schematic so, only the Symbol mgmt is shown ( the same applies to when you’re in the PCB).
Back out to the main panel and you should get to both Footprint and Symbol menu item.

Ah, thank you @BlackCoffee , that did it. I didn’t realize the preferences options changed based on context in the app, which now makes perfect sense.

I clicked the PCB editor button and got the option to add default or import footprint libraries. And now the PBC layout editor the Preference menu, of course, shows the option to manage footprints.

I linked screenshots above because my noob limit is only one image embed per post.

Many thanks for the quick response and for getting me out of this hole :slight_smile: :hugs:

2 Likes

Information about the forum use can be found in the FAQ, linked here:https://forum.kicad.info/t/new-member-information/38391

Welcome :slightly_smiling_face:

You’re ‘basic’ now. :wink:

@hermit

Awwww, I was going to let the Honda person earn his stripes :grin:

Thank you all - much appreciated :slight_smile:

1 Like