Need Help Setting Correct Pins for Simulation Model

I am trying to use a fuse model from Intusoft -

I have a simple circuit set up and “running” in that the voltage source works and current runs through the fuse and resistor. The problem is the fuse does not blow. It is set, based on the model parameters, to blow at 2 A, but happily passes 45 A.I think the parameters are correct.

I noticed that the fuse model uses pins 1 and 4 whereas the schematic uses pins 1 and 2. Perhaps that is the issue? How do I tell kicad/spice/the simulation gods that the fuse model is based on pins 1 and 4. Bonus round question - what is happening on non-existent pins 2 an 3?


fuse_model_test_1.kicad_sch (11.4 KB)
fuse_model_2.spi (1.1 KB)
fuse_model_test_1.wbk (24 Bytes)

First, always tick the box “Show pin numbers” for every device. That’s immensely helpful when simulating.
Second, use this information for the SPICE models attached to each device. The pin numbers should (if necessary) be entered in the “Alternate node sequence” field in the SPICE model.

No, that’s not an issue. The subcircuit pin names are deliberate, the nodes are used inside of the subcircuit. The subcircuit has 2 connections, to be connected to the outside world.

The fuse does not fuse.

There seems to be a bug in your fuse model.

Try this one:
fuse_model_3.spi (1.2 KB)

Wow…that is very cool. I couldn’t figure out how to make the parameter substitutions in the model, so I wrote a python script to calculate the values and put them back into the model. Which is, btw, what the article said to do (e.g. calculate the values by hand). Was the bug in my calculations, as I don’t see any other changes to the model other than substituting the parameters at simulation time?

I see you set an IB of 5 A. However, the model simulation shows a breaking point at 14.4 A. I guess the model is not very good overall.

Any suggestions for a better fuse model?

Thanks again!