My downloaded footprint is not appearing


#1

Hello,

I have downloaded a footprint from a web of a pin header and after copying it to my own-made footprint folder, I’m not able to load it in the footprint editor.

Also there is something that call my attention about that:

The footprint that has not the same type is the one that I have downloaded. The name has the .kicad_mod. The others are made by me.
About the question that maybe is not compatible with Kicad, the answer is that the owner had different footprints depending on the software you are interested in. I downloaded the Kicad one.:slight_smile:

Thanks!
Marc


#2

So is this solved now?


#3

No. What I wrote is the problem I have, the .mod file that I have downloaded is in my folder.pretty with my own-made footprints but I’m not able to select this footprint in the footprint Editor, neither to assign it to any symbol…


#4

.mod is the old kicad file format. It is a full library not a single part. Move it into the same folder as your pretty folder (so one level higher) and then add it using the library manager. You can then copy the footprint contained in that lib into the .pretty lib using the footprint editor.


#5


That’s the 3 files that I have now on the folder that you said. In the .pretty that appears I have my own footprints. The .lib that appears I added it on the library manager and I have the respective symbols. The same directory, where the .mod is placed, is added also in the Library manager of the footprint editor, but still no way to find the footprint of this file…

EDIT: I wrote I have the footprints, but was wrong, I have the symbols!


#6

you need to add the pinheaderconnector.mod file using the footprint library manager. (The .lib file is for symbols so add that to the symbol library table using the symbol library manager)


#7

But I can’t add the file, I just can add (or know how to add) the whole folder, so the .mod file is in the Kicad Projects folder and I have it added like I did with my own footprint folder:
image


#8

The .mod file is a library itself.

Add it, in pcbnew, the same way as you added the .pretty folder. You will see the word “legacy” under the plugin tab column.

Once you have loaded the .mod library, you may want to export the pin headers to the new format, i.e., one file .kicad_mod per footprint into a .pretty folder.


#9

I get what you mean, but when I search for the file in the library manager (ofc in the folder where it is placed) It does not appear. If I select the folder as the directory where the mod file is, still I can’t use these footprints :frowning:


#10

Of course not. The .mod is not a footprint but a library.
Are you sure you navigate to the folder the .mod file is into?

In pcbnew, Preferences -> manage footprint librarires and button Browse libraries until you find the .mod file.


#11

image
here is the file and the folder where is located.

image

and this image shows that in the footprint libraries the folder is activated. I can not activate only the .mod file because when I click in browse and I go into the folder there is no file appearing…


#12

Do not place the mod file inside a pretty folder!
place it one directory higher.

Then go to the library manager (footprint editor -> preferences -> footprint library manager)
In it press the browse button (below the list of active libraries)
A tool similar to a filebrowser will open. Use this tool to navigate to the place where you have the pinheader.mod file. select that file and press open (or double click onto the pinheader.mod file)
If you do not get any error message then the .mod file is indeed an old kicad footprint library file. If you get an error message then the .mod file is something different. (If you get an error message then please give us the full error message text in english.)

You might want to switch kicad to english such that you have it easier to understand what we talk about. KiCad main window -> preferences -> language (switch it from system default to english)


#13

It is a good recommendation for managing libraries, but it is not mandatory in order to add the library to the fp-lib-table. Just added successfully with v5.0.1 in kubuntu 14.04.

In Spanish:
In pcbnew, Preferencias-> Administrar librerías de huellas y botón “explorar librerías…”


#14

After moving the file to Kicad project ( the higher folder instead of the subfolder .pretty), it is still the same. I go to preferences, footprint library manager, browse button, I click on the folder in which the file is located but it does not appear…


#15

Is it possible that the file has a second file extension? Make sure you select “show file extension” in windows explorer to check that.


#16

If it’s a true .mod file he should be able to open it with any text editor and look inside… was human readable after all, no?


#17

After opening it with a text editor that’s what is inside:
PCBNEW-LibModule-V1

encoding utf-8

Units mm
$INDEX
SOIC127P600X175-8N
HDRV2W64P0X254_1X2_508X254X940P
$EndINDEX
$MODULE HDRV2W64P0X254_1X2_508X254X940P
Po 0 0 0 15 5bf3e7bb 00000000 ~~
Li HDRV2W64P0X254_1X2_508X254X940P
Cd W81102T3825RC
Kw Connector
Sc 0
At STD
AR
Op 0 0 0
T0 0 0 1.27 1.27 0 0.254 N V 21 N “J**”
T1 0 0 1.27 1.27 0 0.254 N I 21 N “HDRV2W64P0X254_1X2_508X254X940P”
DS 1.77 1.67 -4.31 1.67 0.05 24
DS -4.31 1.67 -4.31 -1.67 0.05 24
DS -4.31 -1.67 1.77 -1.67 0.05 24
DS 1.77 -1.67 1.77 1.67 0.05 24
DS 1.52 1.42 -4.06 1.42 0.1 24
DS -4.06 1.42 -4.06 -1.42 0.1 24
DS -4.06 -1.42 1.52 -1.42 0.1 24
DS 1.52 -1.42 1.52 1.42 0.1 24
DS 0 1.42 -4.06 1.42 0.2 21
DS -4.06 1.42 -4.06 -1.42 0.2 21
DS -4.06 -1.42 1.52 -1.42 0.2 21
DS 1.52 -1.42 1.52 0 0.2 21
$PAD
Po 0 0
Sh “1” R 1.65 1.65 0 0 900
Dr 1.1 0 0
At STD N 00E0FFFF
Ne 0 “”
$EndPAD
$PAD
Po -2.54 0
Sh “2” C 1.65 1.65 0 0 900
Dr 1.1 0 0
At STD N 00E0FFFF
Ne 0 “”
$EndPAD
$EndMODULE HDRV2W64P0X254_1X2_508X254X940P
$MODULE SOIC127P600X175-8N
Po 0 0 0 15 58bec2a6 00000000 ~~
Li SOIC127P600X175-8N
Cd D (R-PDSO-G8)
Kw Integrated Circuit
Sc 0
At SMD
AR
Op 0 0 0
T0 0 0 1.27 1.27 0 0.254 N V 21 N “IC**”
T1 0 0 1.27 1.27 0 0.254 N I 21 N “SOIC127P600X175-8N”
DS -3.725 -2.75 3.725 -2.75 0.05 24
DS 3.725 -2.75 3.725 2.75 0.05 24
DS 3.725 2.75 -3.725 2.75 0.05 24
DS -3.725 2.75 -3.725 -2.75 0.05 24
DS -1.95 -2.45 1.95 -2.45 0.1 24
DS 1.95 -2.45 1.95 2.45 0.1 24
DS 1.95 2.45 -1.95 2.45 0.1 24
DS -1.95 2.45 -1.95 -2.45 0.1 24
DS -1.95 -1.18 -0.68 -2.45 0.1 24
DS -1.6 -2.45 1.6 -2.45 0.2 21
DS 1.6 -2.45 1.6 2.45 0.2 21
DS 1.6 2.45 -1.6 2.45 0.2 21
DS -1.6 2.45 -1.6 -2.45 0.2 21
DC -3.475 -3.81 -3.158 -3.81 0.254 21
$PAD
Po -2.712 -1.905
Sh “1” R 0.65 1.525 0 0 900
At SMD N 00888000
Ne 0 “”
$EndPAD
$PAD
Po -2.712 -0.635
Sh “2” R 0.65 1.525 0 0 900
At SMD N 00888000
Ne 0 “”
$EndPAD
$PAD
Po -2.712 0.635
Sh “3” R 0.65 1.525 0 0 900
At SMD N 00888000
Ne 0 “”
$EndPAD
$PAD
Po -2.712 1.905
Sh “4” R 0.65 1.525 0 0 900
At SMD N 00888000
Ne 0 “”
$EndPAD
$PAD
Po 2.712 1.905
Sh “5” R 0.65 1.525 0 0 900
At SMD N 00888000
Ne 0 “”
$EndPAD
$PAD
Po 2.712 0.635
Sh “6” R 0.65 1.525 0 0 900
At SMD N 00888000
Ne 0 “”
$EndPAD
$PAD
Po 2.712 -0.635
Sh “7” R 0.65 1.525 0 0 900
At SMD N 00888000
Ne 0 “”
$EndPAD
$PAD
Po 2.712 -1.905
Sh “8” R 0.65 1.525 0 0 900
At SMD N 00888000
Ne 0 “”
$EndPAD
$EndMODULE SOIC127P600X175-8N
$EndLIBRARY

I attach the file in case it is necessary:
pinheaderconnector.mod.mod (2.5 KB)


#18

Did you check the file name extension as i suggested above? (it looks like you have a double file ending)


#19

I don’t know if that’s what you were asking but it appears that the file extension is .mod . The file name had an extra .mod(the downloaded footprint came with it) and I deleted it with no problem but still I can not open the file in the library manager
image


#20

I made a short screencast of my process of adding the lib to KiCads library table and opening a footprint from it: