My downloaded footprint is not appearing


#21

Sorry for my late answer.

I promise I do the same, I did now it again step by step like you did, showing all the supported libraries in the browser options and when I’m in the folder with the .mod file it doesn’t appear (I downloaded it again like you did also but the same is happening…)

Is there any way that you could send me the footprint with the new format? so I just have to download and copy it to my folder…

Thanks!

EDIT:
I noticed that when I try to save the file in my folder when I download it from this web as you did, in the type of file I can select “Quickfield File” (FEM Software) or all files. If I select all files and keep the extension .mod it is also saved as quickfield file… maybe that is the problem


#22

Could someone answer please?

Thanks!


#23

Double-click on the folder to enter the folder.
At least in linux it works.
With .mod.mod and wit .mod only; inside a .pretty folder and in any other folder.


#24

I did it but still there is no file, with .mod or with.mod.mod…


#25

image

In this picture you can see that inside the Kicad project folders there is no .mod file but other folders (kicad project is maximized).

image

In this one you can see that the .mod file is inside the Kicad project folders…


#26

Is it possible that you are in the symbol editor instead of the footprint editor? (please switch kicad to english if you post screenshots to an international forum as already instructed above)


#27

Yes sorry, forgot to switch the language.
No, I’m already in the footprint editor because the symbol that I have downloaded for the schematic is working properly, but not the .mod

Librería de huellas (appears in the first photo) means Footprint libraries.

Important EDIT:
After switching the language from Spanish to English then the file finally appeared in the library browser. I suppose that’s a bug or something. I think I finally got it!


#28

That would definitely be a bug. Would you care to report it over at the bugtracker? (I have a wage feeling that i read something about translated file endings on the mailing list some time back.)


#29

I have reported this Bug #1806446


#30

Thanks Pedro! Hope it is fixed soon :slight_smile:


#31

Another bug or detail that I found is in the “text and drawings”, if I modify something there and then just press the enter button to accept the changes they don’t get modified. I mean the window closes like changes are done but they aren’t.


#32

It is a bug candidate, since Enter should save the changes or do nothing.

If the system is in Spanish, (the system, not KiCad) the Aceptar button or alt+A work as expected.


#33

Yes I have the system in spanish and it happened to me with both Kicad in spanish and english. I press the enter button to accept the new settings but they aren’t applied, I have to do it clicking with the mouse in the OK button. It’s like the enter is pressing the cancel but in the window it appears by default that the OK is the selected one.


#34

This is the updated translation file. Thanks to Iñigo Figuero.
Copy it under …/kicad/internat/es

kicad.mo (480.3 KB)