Move routed track to another layer fails

In this article it suggests using track properties “e” to change the layer of a track.

When I do that with Application: Pcbnew Version: (5.1.6)-1, release build
Platform: Windows 10 (build 9200), 64-bit edition, 64 bit,
it does not work as expected.
Instead of changing layers, the selected track simply dissapears.
Pressing F3 does not display the track in a redraw.
CTRL-Z brings it back on the original layer.

What is the correct process to move a track to another layer?

Most likely cause is that you’ve changed it to a layer that is currently turned off.
If the problem persists, first try updating to a more recent KiCad version. V5.1.6 is 2 ticks behind and half a year old:

I can also not think of a good reason to stay with V5.1.6. Updates in the last digit only indicate bug fixes.

1 Like

@paulvdh, thanks for the reply. There are only two choices for the layer drop-down. F.Cu and B.Cu. Both are active and in use.
Agree on updating, but experience has taught me to not update tools during projects. If 5.1.8 is a “low risk”, and it would solve more bugs than it introduces, I might consider breaking that guideline…

It is not clear what your expected behavior is.
You only see two copper layers because you are making a dual layer board. If you want more copper layers, then adjust them in:
Pcbnew / File / Board Setup / Layers

If tracks seem to disappear when you move them from the Front to the Back Copper layer, then it is likely because you have turned the visibility of that layer of. You can select the visibility of the layers in the layers manager on the right side of the screen. (The checkbox at the B.Cu layer)

You can also right click on the layers manager for a pop up menu with some presets for which layers are visible.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.