Move a footprint snapping on pads / graphics

Hi, some time ago when we had version 6.0.1 I opened this thread with the same topic. I see the related issue here is marked as fix-released, but in the new 7.0.2 version I get the same identical problem.

The issue is that even if I’ve the magnetic points set as “Always” in the preferences, and even if I’ve selected the appropriate layer, when I click and drag on a footprint while “hovering on a pad” to move it the footprint moves snapping with respect to a point of the grid. IMHO the user should be able to move the footprint snapping from a pad, to easily align them. To also have the possibility to snap on graphic elements of the footprint, like a cross typically put on the center of the component on a mechanical layer, would be even better.

Hi @Navalog

I’m having difficulty understanding your issue, so I’ll list the rules moving a footprint with the magnetic points set to “Always”.

  • If the cursor is on a pad, only that pad is selected.

  • If the cursor is very close to, or inside the courtyard, and close to a pad, the cursor will jump to that pad and select the entire footprint.

  • If the cursor is close to the “Anchor”, the cursor will jump to that anchor and select the entire footprint.
    The Anchor shows as a small cross, the color of which may be found in the Appearance Manager > Objects.

  • The first jump in the move will place the pad or footprint on the current grid if it is not so located. Consequent moving will jump the footprint only to grid positions.

This is partially covered above, in the case of library footprints that have the Anchor in the centre of the footprint.
In the case of the Anchor not being in the center of the footprint, it is up to the user to modify the footprint in a personal library so the Anchor is placed where the user requires.

I hope this helps and possibly answers your questions.

Just for interests sake, and to answer a few other questions you may have (EEVBlog), this is a through hole footprint I created entirely with the Kicad Footprint Editor.
Note the positions and shapes of the holes in the pads and the Anchor position of the footprint.


Hi @ jmk, thank you for answering.
I’ll try to explain in a better way the issue:

I’m in the PCB Editor and I’m moving footprints which I will then join with tracks, polygons, VIAs etc.
I need to align those terminal blocks connectors. I was expecting to be able to click and drag on one of them, closely to one of its pads or even better over the pad, to “start the moving operation” with the cursor automatically snapped on the center of the pad. This does not happen, the moving operation starts (and then I’m dragging the component until I leave the left click) not on the center of a pad and not on the footprint anchor, but in the same position of the cursor, which is a multiple of the grid since I’ve the grid snapping enabled.

I made sure to have “Magnetic Points” set to Always for the options “Snap to pads:”, “Snap to tracks”, “Snap to graphics:”. Also I checked the footprint anchor of the components in the footprint library, the anchor is correctly set in the center of the footprint.

Am I making any mistake? Is this a feature not supported yet?

Thank you

How is the setting for Preferences–>common–>warp mouse to origin of moved object?

1 Like

@mf_ibfeew warp mouse to origin of moved object was disabled, I enabled it solving the issue, thank you very much! Maybe it’s just me, but that option over there is easy to miss even if it’s in the first page of the preferences

One other thing @Navalog, I should have written in my first comment:

Only hover over footprint. Do not “left click select”.

Hover then hit the M key and the actions listed above will occur as long as the mouse is as warped as @mf_ibfeew recommends. :smile:

Hi @jmk , I’m just an accustomed Altium user which I use everyday professionally, to left click it’s a long habit : D
But thank you for the suggestion!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.