Mouse Cursor Rough Movement

My mouse cursor has become ‘rough and jerky’ moving around the schematic sheet. This started the other day or so. I move the mouse and have to wait a couple seconds for the cursor to move. It’s really irritating, especially placing components. Any ideas?

my system:
Ubuntu 18.04.3
Intel G630
8Gig ram
Intel built in graphics

And what is your kicad version?

5.1.4 e60b266~84~Ubuntu18.04.1

This problem with the mouse is making EeSchema program virtually unusable! I found something in the known bug page about making a script in the conf.d directory. It has to do with the Intel HD graphics with laptops. My Open GL render version is llvmpipe (LLVM 8.0) 3.1 Mesa 19.0.8 set for direct rendering. Would this bug fix work for my system? I don’t want to monkey with conf files unless I know this is a fix.


Sounds pretty much like you are in for some driver updates and/or microcode updates.

Your issue has unlikely something to do with KiCad’s graphic rendering infrastructure.

I was just checking out Preferences and I was set for ‘Ultra High Quality’. I set rendering to ‘no antialiasing’. I’m back to normal mouse movements and all the laggy/choppy movement is gone. I will look into some of the Ubuntu forums I frequent and see if I can glean any answers. I probably should go to a low end Ati/Nvidia graphics card. I’ve had problems with Intel HD in other programs.

Thanks for the input!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.