Migrate Libraries for 5.99

This seems to be a loop I can’t get out of. I’ll try and delete the library manually.

The same problem than Missing libraries and 3d models in 5.99 ?

I have reloaded (Mac) Kicad 5.99 twice and still can’t seem to get symbol libraries to show up. Libraries are where they are supposed to be Preferences>Configure Paths. When I try to place a new symbol, library names show up, but no symbols in the browser window.

The help file says these paths should be local paths. This is a little ambiguous because it could also refer to user defined libraries. In the meantime my user defined libraries are the only ones that DO show up.

I feel this is a path issue and am looking around for other places where these paths are defined.

On a Mac, I deleted my preferences file here

Restarted Kicad and chose “load the default option” or something similar
Problem fixed

1 Like

Have the same problem with 5.99 on a Linux machine running Ubuntu 21.04. Everything works just fine until I try to place a part. Then I get the same error as mentioned in the original post in this thread. I don’t have a 5.99 or a Preferences folder. Have hundreds of kicad* folders of course.

Anyone know where the preferences file would be for me?


Okay, I found the 5.99 directory, dunno why search didn’t find it yesterday. But…there isn’t any ‘preferences’ file or folder in that directory. There are 14 files and two folders. But nothing that says ‘preferences’. Doing another search of ‘preferences’ brings up hundreds of files with no clue of their home directory. I need to find a better file app for sure. But, any reason there’s no ‘preferences’ file in the 5.99 folder?

BTW, when I installed KiCad, I used defaults.

Any suggestion of where it might be? Or why it’s not it the 5.99 directory? Thanks for the help.

There are several .json files in that directory. Open them up in a text editor when Kicad is closed. You can set many preferences there. It’s also supposed to be OK to delete them and they will be replaced with defaults. You probably don’t want to do that with the files that have library information because it takes a while to get libraries set up correctly, as I’ve found.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.